Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have the following setup in my home office:

  • Fiber-optic service from my service provider passes through the service provider's ONT in the basement and into my apartment via an Ethernet cable

  • Ethernet cable connects to a switch (NetGear GS105E)

  • One port of the switch connects directly to my home server machine using DHCP with the service provider. THIS CURRENTLY WORKS

  • A second port of the switch connects directly to a second dedicated static IP port on my home server machine (I use this for remote management). I pay for this static IP from my service provider. THIS CURRENTLY WORKS

  • A third port of the switch connects to a wireless router (NetGear WNR2000), which attempts to pull up a second dynamic IP using DHCP with the service provider. THIS DOES NOT WORK: Release/Renew pulls up 0.0.0.0

My service provider provides 2 dynamic IP addresses (in addition to the static). I have called the service provider and both dynamic addresses are available (and not locked to some lease timeout for a previous connection). As noted above, one and only one of these dynamic IP addresses currently works just fine.

If I connect the router DIRECTLY to the incoming cable (removing the switch), the router immediately pulls up a proper dynamic IP from the service provider.

It seems clear to me that the router is somehow in conflict with the switch.

The switch has an administrative interface which allows me to connect to the switch as an independent IP device, which I have used to change settings on the switch to attempt to resolve the problem, as follows.

My router provides a local network with the standard 192.168.1.xxx subnet.

I have attempted multiple settings on the NetGear switch to overcome the problem:

  • "DHCP mode" which causes the switch to provide itself a 192.168.0.xxx address.

  • Static mode, in which I type 192.168.1.100 for the switch. NOTE: A gateway is also requested, and I have NO IDEA what gateway to use here (using the router as a gateway isn't correct, and the switch cannot see the router's 192.168.1.xxx subnet in any case). I do not know if this gateway is the problem, or not.

In other words, I have set the subnet of the switch's IP both to be the SAME AS, and DIFFERENT FROM, the router's subnet (though again, I don't see why this should matter since the switch cannot see the router's LAN-side subnet).

Can someone please tell me what I must do to get the router to pull up a dynamic IP through the switch?

share|improve this question

migrated from serverfault.com Feb 10 '13 at 21:21

This question came from our site for system and network administrators.

3 Answers 3

If you connect the WLAN router to the (DHCP) server port, does DHCP work then for the router? If so then I guess the ports are configured differently. Look for this difference in the switch management, that should solve the problem.

The gateway for the switch is the same as for your server but the switch should not need a gateway.

I don't understand "the switch cannot see the router's LAN-side subnet". Does the WLAN router have more than one LAN port so that its "WAN" interface is connected to the switch?

share|improve this answer

What happens when you re-order the cabling on the switch? IE. putting the router cable where the computer pulling dhcp (successfully) is.

Also... make sure you're plugging it into the WAN port on your router, it sounds like since the switch pulls an IP when you set the router to DHCP that you actually have it connected to a LAN port. edit* although it works when its connected directly so I'm confident you are.

can you confirm the MAC addresses on the switch?

share|improve this answer

Its hard to troubleshoot remotely but I would try the following

  1. unplug everything (Yes powered off state and all ethernet cables)
  2. Plug in the Router and allow it to boot
  3. Plug in the switch and connect ethernet cable to router
  4. Plug in ONLY the Wireless router and connect it to the switch
  5. At this point with no other devices connected try and renew the DHCP lease

This eliminates other MAC conflicts etc etc. If this is not working make sure you are not managing the switch and blocking DHCP traffic.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.