Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.
defaults write com.apple.desktopservices DSDontWriteNetworkStores true

works on Mac but not Linux. This problem is caused by my use of SSHFS.

share|improve this question

migrated from stackoverflow.com Feb 10 '13 at 21:23

This question came from our site for professional and enthusiast programmers.

1 Answer 1

I am not really familiar with OS X, but it sounds as if your OS X client considers your SSHFS mount to be a local volume and thus the Finder creates cache files on your remote Linux server.

As far as I can tell OSXFUSE filesystems are considered non-local by default. So, first of all, you should make sure that you are not mounting the SSHFS filesystem with the -o local option.

If that was not the problem, then you may need to use the noappledouble mount option for FUSE, which will apparently prevent the creation of some Apple-specific files on the remote server, such as those created by the Finder. I am unaware if using that option has any unwanted side-effects, though.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.