Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

The website does not load. After sometime it displays a message, "Please use a modern browser with JavaScript enabled to use Coursera.". This happens with both the browsers I use, firefox and chrome.

javascript has not been disabled in either of the browsers.

I have the same problem with random websites with being notable, as I access it a lot.

The loading of the websites usually gets to a point where the status bar tells , "Connecting to ...." or "Waiting for ...".

This problem is only with my ubuntu installation. The websites load fine when I attempt to access them from windows.

Could you help me troubleshoot this. This has been particularly bothersome for me as I am taking a MOOC from coursera.

EDIT After seeing a solution to a similar problem, I tried accessing, and through the proxy, While and loaded through the proxy, still says, ""Please use a modern browser with JavaScript enabled to use Coursera."

share|improve this question
In Chrome, try pressing <F12> and clicking Console to see if there are any errors. – Dennis Feb 11 '13 at 1:31
@Dennis, is suddenly loading in chrome. isn't. The console says, "Failed to load resource Failed to load resource";. It's still trying though. – Abhijith Feb 11 '13 at 1:57
Coursera does no user agent checking. The Please use a modern browser... message gets removed with a simple JavaScript instruction unless your browser is IE 7. The only way I can see how this could fail is that the external script could not be loaded. – Dennis Feb 11 '13 at 2:03
@Dennis, Do you have any idea as to why that external script could not be loading? – Abhijith Feb 11 '13 at 2:44
There are many possibilities. It might be a simple problem with the CDN. How many times did it work in Windows? How many times did it not work in Ubuntu? – Dennis Feb 11 '13 at 2:49

I dont advice you to use firefox when visiting because some feature are not supported yet such as the speed change for video.

I had the same problem , I solved it by using google chrome (chromium) but you will need to install the chromium-codecs-ffmpeg-extra package to make the videos work in Chromium.

You can get it here

share|improve this answer is suddenly loading on chromium. :-| – Abhijith Feb 11 '13 at 1:58
What do you mean ? – meda Feb 11 '13 at 2:21
It wasn't until yesterday in chromium. – Abhijith Feb 11 '13 at 2:37

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.