Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When I bring my Macbook to work I often experience really long response times (~60 seconds) when I use google.com / the unified search bar (or whatever it's name is...). When I'm at home or when I use Safari or Firefox everything works fast. I also experience this problem on websites using Google's CDN or API's. My colleagues are having the same issues... It's really annoying when you want to look something up fast. I temporarily switched to DuckDuckGo, but that isn't a solution.

Does anybody know how I can fix this problem? What steps can I follow to find the cause?

share|improve this question
1  
This sounds like a configuration problem at Work if you also experience this problem using Google's CDN and API's –  Ramhound Feb 11 '13 at 13:29
    
That's exactly what I thought... But what setting should be changed? –  thomasjonas Feb 11 '13 at 16:12
    
Your workplace might have an improperly setup filter that causes lag. –  danielcg Feb 12 '13 at 2:36
    
@danielcg25; How would that explain the fact that I only experience the problem using Chrome? How does Chrome create different data/traffic different then Safari (Safari is just working properly...) –  thomasjonas Feb 12 '13 at 9:44
add comment

2 Answers

up vote 1 down vote accepted

It seemed the problem was related to the NSS-SSL library or the SPDY protocol Chrome is using. I have followed the steps that were described by Jamie Starke on this page and now I'm able to use the Google service at normal speed in Chrome!

Windows

  • Right click on the short-cut you’re using to start Chrome
  • Select Properties Modify Target from

    • ...\chrome.exe"

      into

    • ...\chrome.exe" --use-spdy=off --use-system-ssl

      (note: the command line arguments have to go after the quotation marks)

  • Click Apply

  • Close all Chrome windows
  • Restart Chrome

Mac

  • Open the terminal (In your Applications -> Utilities folder)
  • Type into terminal to change to Chrome’s Directory using:

    cd /Applications/Google\ Chrome.app/Contents/MacOS

  • Rename Google Chrome to Chrome in the terminal:

    mv Google\ Chrome Chrome Copy the following 3 lines for the contents of our execution script:

     #!/bin/sh
     # This will execute your Google Chrome with SPDY disabled, and set it to use your System SSL 
     /Applications/Google\ Chrome.app/Contents/MacOS/Chrome --use-spdy=off --use-system-ssl 
    
  • Type the following into the Terminal to make a file from what you just copied:

    pbpaste > Google\ Chrome

  • Type the following into the terminal to it so our new Google Chrome can run: chmod +x Google\ Chrome
  • Close Google Chrome using the Apple menu, or Command-Q:
  • Restart Google Chrome
share|improve this answer
add comment

Does your network at work or the network at home have IPv6 enabled?

It sounds like one of them does, and IPv6 connectivity is either not working properly or your laptop is caching the DNS results and trying to use IPv6 in the wrong situation.

A couple of steps to figure this out: + check if any of your network cards have an IPv6 address associated with them (not starting with fe80). + if that's the case do a dig -t aaaa google.com and see if it returns a result + perform ping6 google.com and see if you get a reply.

If you do have a proper IPv6 address, and the last two steps fail, something is wrong, and it should be fixed. Temporarily disabling IPv6 would be a quick solution.

share|improve this answer
    
Thanks for your response. I'm not sure how IPv6 can be the cause of this problem. When I look at my DNS settings (chrome://net-internals/) I saw that IPv6 is enabled. And like said: Safari and Firefox don't have these problems... How can I check if any network card have IPv6 addresses associated with them? Should I also be able to see this using a traceroute or something? –  thomasjonas Feb 11 '13 at 16:11
    
Sorry, I missed that you did not have the issues in Safari or Firefox. If you're running Windows you should be able to run "ipconfig /all" in a command prompt, otherwise "ifconfig" should show you the addresses on your interfaces. –  Jeroen Feb 12 '13 at 15:58
    
Just saw a major typo, I saw that IPv6 is disabled in Chrome using chrome://net-internals... So is it save to say that IPv6 isn't the cause of the problem (since Chrome doesn't have IPv6 enabled and I don't have an IPv6 address associated with my network card (just checked using ifconfig, only have a fe80 address)) –  thomasjonas Feb 12 '13 at 16:07
    
What happens when you try to ping google.com? Do you get normal response times? –  Jeroen Feb 12 '13 at 19:46
    
Sorry for the late reply... After 100 pings I get an average of 21.6 ms. That's seems fine to me. –  thomasjonas Feb 18 '13 at 14:52
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.