Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

When telneting to a windows host from a linux guest, attempts to use the backspace key leads to odd characters being output - and nothing being deleted.

Is there something to get the windows telnet service to behave "normally" for this key press?

I am using the /usr/bin/telnet client - from an FC17 machine, from a bash session in GNOME Terminal 3.4.1.1. The $TERM variable is xterm.

If I telnet from another windows machine to the server, I don't see the same behaviour - so there must be some setting in the client.

share|improve this question
    
sounds like a rubbish client! – barlop Feb 11 '13 at 16:58
    
Unhelpful. This isn't some exotic weird client. This is one that is standard. – Danny Staple Feb 13 '13 at 10:29
    
well windows has a rubbish telnet client so many people use putty. If an OS has a rubbish telnet client it's not unhelpful to know it and then use a recommended alternative. I'm not a big linux user but what you describe sounds like what i've seen from a bad telnet client and would make me look at using a different telnet client. A popular one. – barlop Feb 13 '13 at 20:36
    
Hmm - there is a putty build for linux. I'll try that and see if it works for this... – Danny Staple Feb 14 '13 at 10:26
    
Hmm - no better - are there recommended settings for a windows host in putty? – Danny Staple Feb 14 '13 at 10:35

You must log in to answer this question.

Browse other questions tagged .