Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am running an Acer AspireOne AOD250. Doing a clean reinstall of W7x64 Ultimate. My problem is very similar to this one, except that I am installing from a USB as the Acer AspireOne does not have a CD/DVD drive.

What I have tried;

  1. Extracted HDD
  2. Ran it using an enclosure on another computer.
  3. Ran "diskpart">"list disk" and got the following

(I have no way of taking screenshots from the acer as the previous OS has already been wiped so bear with me and the alternate format of the information documented below.)

Disk####; Disk 0, Disk 1, Disk 2

Status; Online, Online, Online

Size; 149GB, 14GB, 3774MB

Free; 0B, 0B, 3774MB

Disk 0 is the Internal SATA HDD on the AspireOne

Disk 1 is my 16GB Toshiba Flash Drive with W7x86 Installation on it

Disk 2 is ??

(I am doing this for a friend who put a pirated version of W7Pro on it before). Also this Disk 2 doesn't come up in the "Install Windows; Where do you want to install Windows?" dialog, which baffles me and makes me wonder if it has something to do with the system partition creation/recognition problem that I am having.

  1. select disk 0

  2. Used both 'clean' and 'clean all' respectively on several different tries.

  3. create partition primary

  4. active

  5. Got the same picture as the link mentioned above "Setup was unable... etc.".

  6. Tried to make the System drive both in my other computer and in Win7 Installation Setup to no avail.

  7. Bios is set to boot from the flash-drive first and HDD second.

  8. To be sure; I am not getting the confirmation dialog about making the system partition when I delete and format the 150GB drive in W7x86 setup. Instead the computer just formats the computer and then when I hit next gives me the "Setup was unable...etc" error.

  9. Also, when I formatted the drive with a System drive and activated it and then also added the regular primary partition, the same error was given when I went into windows install and selected the primary partition 'Setup was unable...'.

  10. Just to see what it would do, I even selected the 180GB active system partition once and hit next and it gave me an expected 'Not enough room to install Win7 error'.

I am stumped and frustrated. I would start swearing about the stupid engineers at Microsoft, except that as a Mechanical Engineer myself, I know that 90%'ish of the time people who do that are just too ignorant to get the answer they need/ or to understand the reason things are designed the way they are.

Thanks for any help that anyone can give me. And as I am someone who is on the Autistic spectrum specific responses are much easier for me to understand then general instructions (step-by-step specifics if you have the ability and time...or applicable links to step-by-steps). Sorry for the length of my post.

Addendums/Replies: I downloaded the drivers for the Acer Aspire One AOD250, and made sure to load the compatible W7x86 SATA driver and install it in the W7x86 Installation. It didn't seem to make a difference, but I could have done it improperly.

share|improve this question
add comment

3 Answers

Clean the disk, removing all partitions, then try restarting the install

share|improve this answer
    
Thanks. I did what you asked a couple times over now, but I will do it again and hopefully post some pics so you can have a better idea of what I have. Making the pictures as I am typing this so hold tight for the post. –  M98Ranger Feb 12 '13 at 1:19
    
I did what you told me and got the same result when I placed my hd back in the computer and ran Win7 setup again. Previously, too, I had made two partitions, one ~180MB/Primary/Active and the other 148GB+/Primary...both NTFS and the same setup error arose. –  M98Ranger Feb 12 '13 at 3:10
    
Was on the phone when typing that. What I mean, @M98Ranger, is to clean off the partition table completely, so there are NO partitions listed in DISKPART –  Canadian Luke Feb 12 '13 at 3:53
    
If you mean make the 150GB drive an unallocated space, then restart and try it from there, I did that. I also did; clean all, create primary partition, format fs=ntfs label="W7x86", active....restart setup, got same error. Also, I did same as above, but with quick format...as I am reasonably sure that has nothing to do with the error as it has already been fully cleaned multiple times. Also, I changed the thumb-drive to use fat32 part last night (instead of ntfs). This problem is killing me. –  M98Ranger Feb 13 '13 at 1:41
    
Thanks for your time Luke, if I could I would vote you up. I figured it out. The mystery drive was the problem. I had installed windows on 3 other Acer One Netbooks and all of them had a memory card slot, but none had the card in it, so I guess I just 'assumed' that the one I was working on had just the spacer (rather than the actual card in the slot). Anyhow, took the card out, pressed format--> Okay---> and Next and it is now finishing up installation. Thanks again for your time. –  M98Ranger Feb 13 '13 at 17:29
show 1 more comment

(As posted by m98ranger)

Make sure that if you have a memory card in it's slot take that sucker out, or it will give you this error. Basically, I took the card out, restarted setup, hit Format > OKay > Next and now W7x32 is installed.

share|improve this answer
add comment

I have found one tricky solution which not require any disk manipulation. Step-by-step instruction can be found here

  • When you see the error – remove the flash drive from the computer
  • Press exit (red cross in the top right corner)
  • Start installation from the beginning (without reboot)
  • After selecting Windows 7 edition you will get new error
  • Press OK in error window, you will be redirected to installation main menu
  • Insert your USB Flash drive in to the computer
  • Install windows
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.