Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I receive this message when I try to install Windows 7 on a GPT Disk

The partitions on the disk selected for installation are not in the recommended order. For additional information about installing to GPT disks go to the Microsoft website (www.microsoft.com) and search for GPT. Do you want to proceed with installation?

Is it safe to click on Yes and proceed with the installation? I have UEFI on my laptop, it is SAMSUNG 300E4C/300E5C/300E7C.

share|improve this question
    
Are you installing on top of the old operating system? Is the disk already formatted? If you don't care about the contents of the HD, you could manually format it and wipe the partition table to get rid of that message. –  Lee Harrison Feb 11 '13 at 20:06
    
@LeeHarrison Yes, I'm installing from my Windows 8 OS, I do not really want to wipe the HDD. Are there any other solutions? –  user197441 Feb 11 '13 at 20:06

1 Answer 1

up vote 0 down vote accepted

First of all, if you are installing onto a "clean" disk with no valuable data, the worst that it can do is fail to install. If it installs and works, cool, you're good to go. If not, you can try to fix it.

Now, I've found some other people on a mailing list who are apparently puzzled by this same problem. Their solution was, in order to play it safe, they wiped the entire hard disk (using a partition utility) and let the Windows Installer create the partitions in the order it wanted them in. This made the error message go away.

So you have two options:

  1. Try it. If it works, you can forget about the problem. If it breaks, you'll end up doing the next step anyway:

  2. Just wipe the entire disk clean (delete all partitions and/or re-initialize the partition table) using a tool such as Gparted, sysresccd, or a Linux live CD. You might even be able to use a Windows PE environment if you insist on not using non-Microsoft tools.

share|improve this answer
    
I've just tried doing this from Windows 8, I noticed that I need to turn off the secure boot option in the BIOS so I did and proceeded with the installation. After copying files it restarted the PC to complete the next step of the setup, but now it is just stuck at Starting Windows and the Windows logo. –  user197441 Feb 11 '13 at 20:07
    
Ack. Didn't know you had Secure Boot enabled. Hopefully you didn't brick your system. There are lots of issues with Samsung UEFI laptops and secure boot that can cause it to be bricked, even if running Windows! –  allquixotic Feb 11 '13 at 20:18
    
Also, you probably can't install Windows 7 "on top of" Windows 8 without losing all your files, especially since Secure Boot was enabled before. Back up your data and start over fresh. –  allquixotic Feb 11 '13 at 20:18
    
I think this is the answer. Thanks for your time :) –  user197441 Feb 11 '13 at 20:21

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.