Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a home network consisting of 1 wireless router connected to the internet, and then a number of clients directly connected to it on both ethernet and wireless, as illustrated below:

All clients are on the same /24 net (192.168.1.0-255). On each device internet connectivity is working very well.

When I start streaming a movie from Netflix on PS3_1 (regular PS3), or even if I stream video locally, from NAS_1 (Synology DS207+), gaming between the LAPTOP's and the DESKTOP computers start lagging a lot (so bad you can't even enjoy a LAN game of WC3 or CS). Online gaming starts lagging too (only noticed it with Diablo 3 though).

How can I troubleshoot this? Can I inspect some traffic on the router maybe?

The WIFI router is a Zyxel P-2812HNU-F1

share|improve this question
    
whats your wired network spec? Gigabit? how good a switch do you have? –  Frank Thomas Feb 11 '13 at 20:36
    
NAS_1, DESKTOP_1 and TV_1 are all plugged directly into the back of the router with standard RJ-45/Cat 5 cables –  Mathias R. Jessen Feb 11 '13 at 20:39
    
I'd certainly recommend putting a switch in line, perhaps moving the Wireless to a WAP, rather than using the ISPs device. your network is a little too big for a single device to keep up with it all, and any congestion will be felt by all nodes the way its set up now. –  Frank Thomas Feb 11 '13 at 20:47
    
Thanks for the recommendation - any good reads/links for setting up home networks? –  Mathias R. Jessen Feb 11 '13 at 20:54

2 Answers 2

up vote 1 down vote accepted

The congestion is occurring because of your WIFI link. You may want to try a different WIFI channel, moving the devices closer or enabling/getting hardware that is capable of handling 2 channels simultaneously and/or working on another band (ie 5 gig) band. Moving as many devices onto the wired connection as you can will also help. (Also, if your WIFI router is not 802.11n, upgrade to 802.11n, and get a router with multiple antennas so it can do MIMO). [ You might also be able to get a small boost by disabling older protocols like 802.11b if all your gear is g capable, or disabling 802.11b and g if all your gear is 802.11n capable]

One way of troubleshooting would be to use ping/mtr and monitor your performance as you do various things (and at various times of the day). Also, using a wifi analyser of some sort to see the noise on channels etc.

share|improve this answer
    
Thanks, I have another AP in spare that I'll try to move all wifi devices to instead. inSSIDer also revealed some interesting stats on the distribution of wifi channels in use in the area, I'll choose a band that is not used. Will report back! –  Mathias R. Jessen Feb 12 '13 at 11:03

Having a look at the traffic is easy if you can install OpenWRT (or similar) on the router. There are even devices which become twice as fast after the change to OpenWRT. So if that is at least a theoretical option for you have a look at the compatibility list on www.openwrt.org. Or consider getting a new one.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.