Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm on a network where we share a media server between all residents. If I connect my laptop directly to the network it detects the media server (through samba) without issues.

Recently I've added a router to my own network to be able to also connect my desktop as well. The problem is that now I've lost access to the network on which the media server resides (probably since I'm on a different subnet now). So my laptop and desktop can't detect the media server any longer. All I now see is the desktop and the laptop itself.

How do I make my router a "transparent" part of the network, so I can once again find the media server? My router is running DD-WRT by the way.

share|improve this question

migrated from serverfault.com Feb 11 '13 at 20:50

This question came from our site for system and network administrators.

    
How does your router connect to the existing network exactly? Do you have a single wired port? –  David Schwartz Feb 11 '13 at 12:57
    
@DavidSchwartz, there's one cable connected to the WAN-port of my router, which gives (or should give) me access to the www and the media server-network. My laptop and desktop are connected to the switch ports on this router (so the LAN ports I guess you'd call it?). –  user119287 Feb 11 '13 at 13:12
    
Yeah, see my answer. You shouldn't be connecting your router's WAN port to your LAN. (Unless you configure the router to use the WAN port as just another LAN port, which I presume you haven't done.) Make sure to disable the DHCP server in your router -- two on one LAN will make big trouble. –  David Schwartz Feb 11 '13 at 13:19
    
@DavidSchwartz, I tried that, but the problem is that the cable that connects me to the buildings LAN also connects me to the www. If I put it in a regular router LAN port, I gain access to the network, but lose my internet connection. –  user119287 Feb 11 '13 at 14:46
    
So troubleshoot to figure out the problem. Did you disable the DHCP server? Did you release/renew your DHCP lease (or reboot)? –  David Schwartz Feb 11 '13 at 14:50

1 Answer 1

  1. You obviously have to configure the WAN port of your router to the MAC address which your Internet gateway expects. I have no idea whether DD-WRT offers that. Could be done with OpenWRT.
  2. Your router must masquerade your connections (NAT).
  3. Depending on the configuration of the network you either have to set the IP address for the router's WAN interface of activate a DHCP client on that interface.
  4. It should be easiest to use DHCP on the LAN ports, too.
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.