Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

When I right-click in a window showing my C:\ directory in Windows 7 and try to create a new text file, I get an error message: "A required privilege is not held by the client." Why is this and how can I change it?

share|improve this question
Can you do it from an elevated notepad? Explorer.exe is not elevated. – Phoshi Oct 13 '09 at 19:36
Yes I can. My question is, why has my root directory been made less accessible in this way? – Tommy Herbert Oct 13 '09 at 19:39
Because if you can access your root, so can IAmAVirus.exe! It's a good thing, honest. – Phoshi Oct 13 '09 at 19:41
up vote 3 down vote accepted

The C: drive is protected from modification by normal users. Unless your an administrator or can elevate another process to administrator, you won't be able to write to C: drive except in your C:/Users/ folder.

More Info

IF you right click C: in the Computer view, go to security, you'll notice that you won't have Write permissions. You get Read/Execute, List Files, and Read.

share|improve this answer
I am an administrator - this is my own laptop. Is there no way to lift the protection? – Tommy Herbert Oct 13 '09 at 19:42
You can try to add Full Access as a permission for your account. But it is not recommended. If you need to store a file somewhere, the best place is on another drive, or in your users folder. – Justin Drury Oct 13 '09 at 19:44
You need to add Full Access to your account on C:\. Since Vista, this directory is protected, as it's one of the favorite places for viruses. In any case, too many irreplaceable system files reside there. – harrymc Oct 13 '09 at 19:49
I understand Phoshi's point that a virus could pose as a user, but I've experimentally granted myself Write permission in C:\\. I still can't create a text file from Explorer, though. – Tommy Herbert Oct 13 '09 at 19:52
You need full access to create a file, iirc. – Justin Drury Oct 13 '09 at 19:55

To fix it, just turn off the User Account Control (UAC). In Windows 8, do not turn off the UAC via control panel, it must go through the registry.

Press keys “Windows Key + R”, type regedit
Locate HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System\EnableLUA
Update the EnableLUA value to 0 (turn if off)
Restart Windows.
share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .