Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I seem to have an odd issue with a dual partitioned usb drive, here is my setup:

I created 2 partitions on my external hard drive. One partition has my bootable Windows environment ( WinPE 3.0 ) NTFS @ 10.0GB - which I set active - and the another partition is NTFS @ ~900GB.

I can boot to this external at anytime via any desktop (HP 7800-8200 SFF) . However, when I take my external to any laptop(HP 2530p, HP 8540p, etc) - I cannot boot to my external harddrive. I this error when I manually specify the system to boot to my USB external Hdd: "Error loading operating system".

This is everything that I have tried[which failed]:

  • Shrinking the partition that holds my bootable OS to 1GB
  • Performing a FULL format of that partition as
    • FAT
    • FAT32
    • NTFS
  • Changed the BIOS of the laptop between both AHCI and IDE
  • Factory defaulted BIOS of the laptop
  • Doing a Chkdsk on the external hdd & repair any bad sectors
  • Made sure my bootable partition was marked as ACTIVE and PRIMARY (not logical)
  • Changed the USB port used
  • Put the WinPE into both partitions

Also, I tried booting to a bootable USB drive (same files, NTFS) with only one partition, which worked.

Note: I checked the MBR of the bootable drive & it looks correct. I dont think this is my issue because it CAN boot to the USB drive when connected to any desktop

The BIOS information on my laptop (HP 2530p) is as follows: ROM Revision 68PSU Ver. F.21 08/02/2012.

Why does this work on my desktops, but not my laptops?

share|improve this question
This is a shot in the dark, but if your active WinPE partition is after other partitions, could that cause the computer to ignore the 'active' flag on some computers? – M98Ranger Feb 12 '13 at 3:49
well I also tried putting the same winpe on both partitions and I still received this error :( - I will update the OP – Zero Stack Feb 12 '13 at 14:55
up vote 0 down vote accepted

I figured out the solution to this.... It seems I wasn't the only one with this issue.

The HP 2530p Elitebooks had a BIOS issue that gets resolved after flashing the BIOS to Revision F22. Download is located here.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.