Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

If I command convert --version it shows this.

bash: /usr/bin/convert: No such file or directory

All what I did was this

1. $ wget ftp://ftp.imagemagick.org/pub/ImageMagick/ImageMagick.tar.gz
2. $ tar xvzf ImageMagick.tar.gz
3. $ cd ImageMagick-6.8.2-10
4. $ ./configure --prefix=/usr/local --with-bzlib=yes --with-fontconfig=yes --with-freetype=yes --with-gslib=yes --with-gvc=yes --with-jpeg=yes --with-jp2=yes --with-png=yes --with-tiff=yes
5. $ make
6. $ make install
share|improve this question

/usr/local/bin is not in $PATH by default in CentOS. Either add it in or run yum install ImageMagick to install ImageMagick from the CentOS repos.

share|improve this answer
    
Thanks That's true but the problem is yum in my CentOS5.8 can install up to the version 6.2.8:( I'd like to install the latest version. – HUSTEN Feb 12 '13 at 5:05
    
That's why I presented it as only one of the options. – Ignacio Vazquez-Abrams Feb 12 '13 at 5:05
    
what should I do? PATH=$PATH:/usr/bin/convert? or PATH=$PATH:/usr/bin? then export PATH? – HUSTEN Feb 12 '13 at 5:07
    
Neither. That's not where you installed it. – Ignacio Vazquez-Abrams Feb 12 '13 at 5:09
1  
/usr/local/bin/convert --version ?? You should be able to run it like this – mcalex Feb 12 '13 at 5:09

Don't go installing software from source unless strictly necessary. I believe ImageMagick is in CentOS, and GraphicsMagick (a fork from the above) is in EPEL

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .