Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I recently ran into a problem where my browsers sometimes suddenly have no internet access, but then my Skype is active and messages pops out and the internet icon displayed that I have internet access. I cannot download and cannot browse the internet even the address: localhost/ (I use XAMPP to setup my local server for testings). Also my torrents seems to work. I need to restart my PC to access the internet.

The diagnose says they cannot find any problem. So in conclusion, I cannot access: local server on my pc, websites, adapter's settings page: setup.net, direct downloads and so on. BUT HAVE CONNECTIONS on Skype and torrents??!!

Please Help! What is the problem my computer goes into? And how to fix it.

share|improve this question
    
Did you check proxy settings for browser especially in IE? –  irvgk Feb 12 '13 at 6:11
    
If you cannot access localhost you have a serious system corruption considering localhost is the local pc and is available when your connected to any network. Pipe the output of ipconfig /all into a text file, remove any public ip address, and post the contents. –  Ramhound Feb 12 '13 at 12:27
    
@Ramhound I will try if I run into the problem again –  Daniel Cheung Feb 13 '13 at 13:24
    
@DanielCheung - What do you mean if you ran in the problem again? I thought you currently had this problem. –  Ramhound Feb 13 '13 at 13:32
    
@Ramhound Sorry, I will edit it –  Daniel Cheung Feb 13 '13 at 14:20

1 Answer 1

up vote 1 down vote accepted

Your DNS is flaky. Skype connects through an IP address, so doesn't need DNS services to work. Your browser needs DNS to resolve hostnames.

Try setting your DNS servers to Google's: 8.8.8.8 and 8.8.4.4

Update: Since you also mentioned torrents, torrent client can open a lot of sockets, and make your router sick. Try and see if you can reproduce the problem with your torrent client shut down.

share|improve this answer
    
sorry for late accept, but I guess you provided the best answer? –  Daniel Cheung Dec 26 at 7:22
    
Thanks. Mine was the best answer of course, since it was the only one there :D –  maksimov 2 days ago
    
anyway, my computer fixed itself, but applying Google's DNS was no use –  Daniel Cheung 2 days ago

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.