Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm using Lenovo G480 and I have problem with LAN cable not detected if it is connected to Router. However if it is directly connected to modem everything works fine. I did so many remedies including uninstall/install LAN driver, remove the battery for 30 minutes and more but no luck the problem still persists.

Updated If the LAN cable or internet cable is directly connected to a router the light that shows if you are connected to internet is not blinking (totally dead. No sign of light). Other machines or work stations are connected to the same router but they are working fine. They have internet connection. Both routers in our office and at home with the different models are not detected by my laptop. However if I unplug the cable from router and connect it directly to Modem my laptop internet connection will become alive.

share|improve this question
    
Can you add what router model and what kind and model of modem you have? –  Stefan Seidel Feb 12 '13 at 8:16
    
What does "cannot detect LAN connection" mean? What does "LAN cable not detected" mean? Does the cable light up at the router end? Does the machine get assigned an IP address? Do other machines connected to the same router work? –  David Schwartz Feb 12 '13 at 8:42
    
To David Schwartz I updated my problem. To "Stefan Seidel" I have no idea about the model but at home I'm using linksys wireless router with 4 LAN slots while in the office we are using DLINK brand –  Jobert Enamno Feb 12 '13 at 9:17
add comment

Know someone who can answer? Share a link to this question via email, Google+, Twitter, or Facebook.

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.