Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

So I installed Windows Mint along side Windows Home XP. The system boots onto the hard drive but the OSvchoice screen flashes up for about 400ms and I hardly have the time to make a choice. Is there a way to increase the time of this?

share|improve this question

migrated from stackoverflow.com Feb 12 '13 at 14:05

This question came from our site for professional and enthusiast programmers.

    
Are you using GRUB, or the Windows bootloader? If GRUB, try holding down the shift key during boot. It's usually configured to forcibly bring up the menu with no timeout. –  uʍop ǝpısdn Feb 11 '13 at 20:23
    
Windows bootloader, I actually had to do this: robert.penz.name/221/… which seems to have fixed things –  Nikos Feb 11 '13 at 21:18
    
@uʍopǝpısdn thing is now, I can't boot linux from those choices (1 is windows and the other is recovery) –  Nikos Feb 11 '13 at 21:29

1 Answer 1

up vote 1 down vote accepted

What you've done via those instructions is replaced the linux bootloader named grub, with the windows bootloader. Windows bootloader has no notion of being able to boot to other operating systems (I bet you're not surprised there), but the linux bootloader grub can boot to many types of OSes, so you want to keep grub installed instead.

I think your original problem was the grub timeout was set too small. Once you get back into your linux partition, edit /boot/grub/grub.cfg, find the lines that say "set timeout=1" or something similar. That's the timeout in seconds for grub's OS selection screen to show before it automatically chooses the default option to boot to. Just change that to something larger. In my install, there's two lines:

terminal_output gfxterm
if [ "${recordfail}" = 1 ]; then
  set timeout=-1
else
  set timeout=10
fi

The timeout=-1 means leave the screen up (don't autoselect) after a failed boot, and the timeout=10 is the default wait. This file is owned by root so you'll have to use sudo to edit it. If you're unfamiliar with doing this, do this at the command line: "sudo pico /boot/grub/grub.cfg".

You'll want to get your grub install back though. Boot to a live CD and follow instructions to reinstall grub to a hard drive. You might just want to google those, I don't remember them off the top of my head.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.