Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I tried uninstalling pathogen but now am getting no filetype detection. With this issue I get no filetype detection and thus no syntax support. Starting vim via vim -V1 I get the following message:

not found in 'runtimepath': "ftdetect/*.vim"

I have spent more time than I'd like already trying to fix this issue, but haven't found anything to help. I wouldn't think pathogen could have crippled file detection this badly. Has anyone had this issue or know how to fix it?

share|improve this question
    
Pathogen certainly didn't cripple anything. Do you have filetype plugin indent on in your ~/.vimrc? Is it before or after the two pathogen lines? Could you post your ~/.vimrc? –  romainl Feb 12 '13 at 15:51
add comment

1 Answer

Your key to solving this problem is the information in :set runtimepath? Your ftdetect directory must be below any of the listed locations, typically the first, ~/.vim/. Check whether there's still something in your ~/.vimrc that modifies the 'runtimepath' setting.

Pathogen installs all plugins in separate bundle/ subdirectories; you need to move those subtrees back into the single consolidated directory to make them work again.

share|improve this answer
    
I never installed ftdetect as a bundle. Isn't that a default vim plugin? My current runtimepath=~/.vim,/usr/local/share/vim/vimfiles,/usr/local/share/vim/vim73,/us‌​r/local/share/vim/vimfiles/after,~/.vim/after –  E-rich Feb 12 '13 at 15:42
    
No, ftdetect is not a default directory. –  romainl Feb 12 '13 at 15:55
    
ftdetect is a default subdirectory of the runtimepath (like autoload, ftplugin, plugin, etc.) It is not a plugin, but a special location with particular semantics. Vim does not ship with any ftdetect scripts (is that what you mean, @romainl?), but you may have installed some (in bundle/<bundlename>/ftdetect/<scriptname>.vim) –  Ingo Karkat Feb 12 '13 at 16:42
    
yes, that's what I meant. –  romainl Feb 12 '13 at 17:13
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.