Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm having a strange issue with Windows Explorer on Windows 7 Professional.

When I try to open it up under different user credentials, I get the following error message:

Windows Cannot access the specified device,path...

The results are the same whether I try it from the context menu or by using runas /user:DOMAIN\User explorer.exe

However, if I open up a Command Orompt (using runas.exe) the behavior is a bit different:

  • Typing in just explorer or explorer.exe results in the same error.
  • Typing in explorer C: or explorer /E,... doesn't run anything. I'm dropped right back to the prompt. The Explorer process doesn't start.

Has anyone seen this behavior before? If so, how can I go about changing it?

share|improve this question

11 Answers 11

up vote 3 down vote accepted

First of all, thank you everyone for the responses.

An update on this. If I make the target domain user a local administrator, I'm able to start Explorer with runas command. However, the new instance of explorer does not start under a different user's credentials.

Aparently, starting with Vista, MS no longer allows multiple instances of explorer.exe with different credentials. It was mentioned here

Anyway, I'm officially giving up on it and looking for a standalone explorer replacement which can be run with RunAs.

share|improve this answer
    
try this. free and portable: mustangpeak.net/ultraexplorer.html –  Molly7244 Dec 29 '09 at 21:28

I see this on programs that lock access to a file or do not have permission to write/access a particular file. I see it a lot with Notepad++ so I just save it to the desktop then copy it over when working on system files. There might be some slight modifications that the developers of those programs may need to do or the way Windows 7 handles it. I see it more in Win2k8 though.

share|improve this answer
1  
I'm just trying to run Windows Explorer under different credentials. No special application. –  Nasir Oct 13 '09 at 21:33
    
Just giving you a reason you would get that. If you are trying to run Explorer and nothing else turn of UAC completely and make sure its killed then start it up in task manger maybe that will work. –  user10547 Oct 14 '09 at 2:56

I sought the advice our microsoft tam and now use Explorer++ you can download it from www.explorerplusplus.com Below is the advice I recieved.


In Win7 we now block launching Explorer in another context. You may have to install a file manager application to do this trick http://blogs.technet.com/elevationpowertoys/archive/2009/11/20/explore-as-administrator-powertoy.aspx

Or

You can launch Explorer in another context provided you kill the first instance before you make the second one, because it’s single instance.

But this would be a wrong way to do and it will be an unsupported scenario, also it would cause some issues.

share|improve this answer
    
Brilliant! Explorer++ worked out perfectly. –  SliverNinja Jun 19 '12 at 13:57

This Windows support article might help.

I tried killing the explorer.exe process first and then running runas /user:DOMAIN\AnotherUser explorer.exe and it replaced my shell with AnotherUser's shell. But logging out from the new shell logs me out entirely.

A blog post talks about setting the Launch folder windows in a separate process but it didn't work for me. YMMV.

share|improve this answer

There is a solution (tested and working for me at least) here.

Basically use Internet Explorer instead of just Windows Explorer; this works for local files.

If you want to access a networked location \\myserver\myshare, then you can type the following into the address bar:

file:\\myserver\myshare
share|improve this answer
1  
While this used to work back in the IE6 days, I don't believe this has worked since IE7 was released –  Rex Aug 25 '10 at 14:31

Aaron Margosis posted an alternative to running Windows Explorer as a different user in Windows 7. You actually use Notepad instead of Explorer.

See the December 7th 2009 comments at the bottom of this page.

share|improve this answer

You can run the Explorer with elevated rights if you disable the Elevated-Unelevated Explorer Factory which blocks all requests to elevate the Explorer.

To do this, start regedit.exe and go to the key HKEY_CLASSES_ROOT\AppID\{CDCBCFCA-3CDC-436f-A4E2-0E02075250C2}. Take ownership of the key and give your account full permissions. Now rename or delete the value RunAs. After doing this, the Elevated-Unelevated Explorer Factory is disabled and when you select "Run as admin" the Explorer runs elevated:

enter image description here

share|improve this answer
    
Thanks, this actually works. You might want to install PrivBar which is a toolbar for explorer that shows with which priviliges it's running. Also, note that you can use "Run as admin" as opposed to "Run as..." + "User: Administrator". –  jdm Jul 6 '13 at 10:46

Check the ownership on explorer.exe Other than that I'm stumped.

share|improve this answer

I have noticed this behaviour too on both the RC and release version. I am currently using 64bit Win 7 Enterprise.

This is quite irritating, as one of the main uses for this is for me to be able to access network resources with an administrator account that are otherwise inaccessible to standard users. Using "explorer.exe /separate" was a dead-cert in XP, but does nothing now. I have tried logging in locally as the user who I want to later run as and setting the "run explorer windows in separate proces option" but again this does not help.

I have seen that this does work on other poeples systems, and there are blog posts explaining run as different user, so perhaps this is a limited to running as domain users?

Also, I only receive the error message if I have previously set Explorer.exe to run as administrator. If this is not set, I get no activity whatsoever. Perhaps when running explorer as a different domain user to the one you are logged in as, elevation is not occuring properly and the account is refused access to the file?

Richard

share|improve this answer

In Windows XP it works like this:

runas /user:domain\username "explorer /separate"

You might try that, the /separate switch. I just trashed my Windows 7 VM, but it was an RC, and I haven't been able to install a new non-RC version yet, so I can't test it right now.

UPDATE: In Vista it attempts to start Explorer, but it never actually appears on the screen, which makes me think this won't work in Windows 7 either.

share|improve this answer
    
yep, just tried it. no dice :-( –  Nasir Oct 14 '09 at 0:42

Just find the shortcut for Windows Explorer in the taskbar but don't mouse-left-click it. Press Shift button on keyboard and mouse-right-click on the Windows Explorer icon, then click on Run as administrator or Run as different user menu.

share|improve this answer
    
Tri Effendi: That does NOT work in Windows 7. –  user47502 Aug 25 '10 at 13:20

protected by Tom Wijsman Sep 13 '11 at 2:59

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.