Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

This question is an exact duplicate of:

My computer won't power up. It might be the power supply, but I'm not sure. How can I tell? Here are my notes.

  • I have a computer that won't power up. The blue LED near the power button flickers briefly, but the fans don't start turning, and it doesn't power on.

  • I thought it might be that the processor fan doesn't work, and the computer turns itself off to protect the processor. But it turns off too fast for that.

  • The power button on the case was loose, and I thought that was the problem, but I opened up the case and accessed the inner button, which isn't loose at all, and the computer still doesn't power up when I press the button.

  • I checked the connectivity of the 2 wires that go from the power switch to the connector on the motherboard, and they're ok.

  • I used to think that those 2 wires would lead into the Power Supply, but I can see that the motherboard needs to control the response to that signal, to have configurable behaviour for what happens when you press the power button or hold it down for 5 seconds.

  • But where does the signal go from that motherboard connector? Where does it continue to the Power Supply? That's what I would check next.

  • My best guess at this point is that the Power Supply is dead, but I measured the voltage of a few of the pins on the connector at the motherboard which is at the end of the wires that come FROM the Power Supply. Many were 0 volts, but one was 5 volts. When I pull the plug from the back of the case, that pin goes to 0 volts. That seems to prove that the Power Supply works, right? Or is it supposed to be 12V?

  • The Power Supply is rated at 300W.

  • This is not my computer. When I opened the box, there was a ton of dust. I used a full-sized vacuum cleaner to get most of it out, and then wiped away the rest. Did this dust clog up the fans and put long-term strain on the Power Supply?

  • While I was getting a flicker of the blue LED when I pressed the power button the first few times, I no longer get even that. This is after taking things apart a bit and putting them back. Maybe there was some residual power left somewhere and now it's used up?

  • What should I try next? Should I install an old Power Supply with a lower rating, just to see if it can power up? I don't want to buy a Power Supply if it's not going to solve the problem.

  • Can I remove some components, to reduce the load, and see if it at least powers up? I already removed the hard drive. This computer was running ok for a few years, though.

  • Any other thoughts?

share|improve this question

marked as duplicate by CharlieRB, Dave M, sudo, ChrisF, Ƭᴇcʜιᴇ007 Feb 13 '13 at 12:24

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

2 Answers 2

Your last 2 thoughts are valid ones.

I would start by removing everything not specifically required to boot up the system (eg everything other then motherboard, ram and graphics card) and see if that boots. If it doesn't, try - temporarily - using an old power supply just to see if it boots up. [ Don't try and run the entire system off the old power supply unless you are sure it can handle the load ].

Based on what you described it does sound entirely likely the power supply is fried.

One other thing, try waiting about 1 minute between turning the power supply off and on again. Sometimes (dodgier ones) take a while to fully discharge and allow you to turn them on again after being powered down - or at least that was the case when I was playing with them.

From memory - and I could be a bit wrong here - a power supply has both 5 volts and 12 volts, 5 volts is used (among other things) for standby. You will need 12 volts to boot most PC's. [ One was red, the other yellow, can't recall which was which ]

share|improve this answer

Trying another PS is a good idea, especially with minimum devices connected. Google online, as the power connector is standard and there are specific pins for 5V, 12V (I don't recall if + and -), GND, and power control (there are pins that are inputs to the power supply for power on/off.

IIRC, you don't want to test the PS w/o it being connected to some load (like the motherboard). Also, some motherboards will have LEDs or will beep with codes that indicate if there is some POST failure.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.