Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

So I have this G: drive which I'm 99% sure I "mounted" using subst to associate a folder with a drive letter. If I double click on it I see the contents of C:\User\Marcel\Google Drive.

Anyway, now I want to get rid of it but I haven't had any luck doing so. I've tried running subst G: /d in both a regular and elevated command prompt, as well as trying to associate a new folder over top of G: and both times I got Invalid parameter - G:. It's also still there after a reboot which is weird because subst isn't supposed to persist over reboots. I've also tried these things in Safe Mode and nothing is different.

I've checked what runs on startup using CCleaner and there's nothing related in there either.

Any ideas on how to resolve this? See screenshot below of the oddity.

bung subst in Windows 7

share|improve this question
Just for giggles try a full power cycle reboot, it may/may not help. – mdpc Feb 12 '13 at 21:54
@mdpc I've had this problem for more than six months and have done about a dozen full power reboots since. – Marcel Feb 12 '13 at 22:01
What does net use say (normal/elevated)? – mousio Feb 12 '13 at 23:06
@mousio New connections will be remembered. There are no entries in the list. for both normal and elevated. – Marcel Feb 15 '13 at 3:15

You probably used subst from an elevated command prompt. When that is done calling subst from a normal command prompt doesn't return the mappings made in the elevated one.

Try calling subst in an elevated commant prompt (start -> cmd -> ctrl+shift+enter or right click and Run as administrator).

share|improve this answer
Still no dice, even from an elevated prompt no mappings are returned. – Marcel Feb 12 '13 at 20:59
Can you check if the source of that letter is the registry key HKEY_LOCAL_MACHINE\SYSTEM\MountedDevices? – mprill Feb 12 '13 at 21:06
Nope, there's several from \DosDevices\B through to \DosDevices\V but no \DosDevices\G. – Marcel Feb 12 '13 at 21:11
I was also having a problem unmounting a subst drive. It turns out that the reverse of what you suggest is true as well. I had mounted it in a non-elevated command prompt and was trying to remove it in an elevated command prompt. Switching to a command prompt with the same lower privilege level fixed the problem. Kudos! – Jim Fell Mar 17 at 23:41

If you just type SUBST by itself, no parameters, it will list all drive letters created by subst, e.g.

C:\>subst Z: C:\Windows
 Z:\: => C:\Windows
C:\>subst z: /D

map Z: to windows folder, show list of mappings, delete Z: mapping, show mappings again (none) So if you don't see it there, it wasn't created by subst.

share|improve this answer

Try net use (as mousio suggests above). Today I had a similar problem with most drives taken by network connections and "net use * /d" was able to make the drive letters available.

D:\>net use
New connections will be remembered.

Status       Local     Remote                    Network
Disconnected K:        \\foo\scratch          Microsoft Windows Network
Disconnected Z:        \\foo\scratch          Microsoft Windows Network
The command completed successfully.

D:\>net use * /d
share|improve this answer
  1. Start / Run / Type "diskmgmt.msc" and press Enter

  2. Right-click C: and select Change Drive Letter and Paths

  3. If G: is listed in addition to C:, select it and click Remove

  4. OK your way out

share|improve this answer
Unfortunately only D: is listed under Change Drive Letter and Paths... for C:. Vice versa. – Marcel Feb 19 '13 at 1:55

Just ran into this issue. Found that the drive letter I was trying to substitute was taken by a virtual drive. So it might be worth checking any virtual drive you may have mounted and unmount them all. e.g. PowerISO or VirtualCloneDrive etc...

share|improve this answer
Does this use the same process as the subst command the OP used? – bertieb Aug 17 '15 at 16:52

Open command prompt and run this command

subst /D G:
share|improve this answer
This does not provide an answer to the question. To critique or request clarification from an author, leave a comment below their post - you can always comment on your own posts, and once you have sufficient reputation you will be able to comment on any post. – AthomSfere May 3 '14 at 20:19

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.