Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Firefox seems to have very recently stopped loading javascript for sites running from localhost, while still working normally on other domains. As someone who writes a fair amount of javascript, I'd like to be able to test it locally. Is there a setting to fix this?

This is on windows 7 pro, running firefox 18.0.2 hitting IIS 7 locally. The problem is recent, and seems to coincide with the release of firefox 18.0.1, although release notes for it don't indicate anything suspicious. Firebug indicates that on pages where some javascript is downloaded from a CDN or similar and some is local, the remote JS downloads and the local JS does not.

share|improve this question
    
Which OS? Which verison of FF? Did it ever work? Have you got a web server setup, or are you just accessing the web files directly (via a localhost UNC path)? Does the FF Error Console report any error messages? Have you tried debugging with Firebug? –  techie007 Feb 12 '13 at 20:35
    
@techie007 Windows 7. 18.0.2. Sure did. Using IIS 7 through the path localhost. The console produces errors for inline code where it exists, generally because of broken dependencies. Tracing through the load with the net panel of firebug shows all local javascript doesn't even start loading. –  Dan Feb 12 '13 at 21:05
    
Check if you have one of the many "block Javascript" filters enabled. Javascript is too often a vector for malware or annoying popups and other "niceties", so as a matter of principle I turn it off by default, it is on only for selected pages (or for a limited time while I visit some random page). Seems Firefox has wised up too... Have you read the full release notes? –  vonbrand Feb 13 '13 at 2:59
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.