Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a Compaq Presario C735ET laptop which is designed only for Windows Vista. There is not any driver for Windows XP or Windows 7 so I am stuck with Vista.

Because I was not very happy with Vista, I installed Ubuntu on this computer, however, for some reason, I needed Vista again and removed Ubuntu. I deleted all partitions except the recovery one. Using Hirens Boot CD v14, I made that partition "not hidden" and "active" but I still could not boot with it. These actions were probably wrong but I just gave it a try.

I used "Startup Repair" option using Vista recovery CD but it did not work.

Then I used "bootrec /fixmbr" and "bootrec /fixboot" commands using the same CD, at command prompt, but they did not help.

Then I messed it even a little more, I tried to manually use bcdedit.exe however it still did not boot. Unfortunately I lost probably already corrupted /boot/bcd file in my recovery partition during this process.

At this point I decided to ask for help here, because I am tired and I know that if I try more I am afraid the situation will get even worse.

I do not have recovery CD's of Vista, we have never had them, and the image of C: drive I've taken with Macrium Reflect did not work, thus I am having all these problems.

Please find "dir /a /s" command output of my recovery partition here: http://goo.gl/WKUeQ

I need to boot with this recovery partition to use this computer. I will greatly appreciate any help.

share|improve this question

As long as you don't mind reformatting I suggest going through this to install Vista: http://en.community.dell.com/support-forums/software-os/w/microsoft_os/3317.2-3-microsoft-windows-vista-official-iso-download-links-digital-river.aspx

Also, a lot of times Vista drivers work on Windows 7. So, if you have a Windows 7 license I would try that first.

share|improve this answer
up vote 0 down vote accepted

I am happy to announce that my problem is solved.

I examined files in my recovery partition and noticed that there is a huge file named "BASE.WIM". I looked into it using 7-zip. It looked like the complete image of original system C: drive.

A quick Google research confirmed my thought: "(Just for reference, as I have noted elsewhere, the wim file can be extracted and deployed directly to the system drive in most HP systems.)" (Source: Tech Support Guy Forums - View Single Post - Solved: HP Recovery via base.wim file.)

Then here is what I've done to solve the issue:

  1. Boot into Mini Windows XP using Hiren's Boot CD.
  2. Extract all files in the BASE.WIM file into C:\ path using 7-zip.
  3. Reboot using Vista Recovery CD.
  4. Startup Repair recognized boot problem and directly asked me to fix it. (Finally!) I accept.
  5. Windows Vista boots from HDD. (Yes!)
  6. Since there is a confusion in drive letters, some things were weird. I fix this problem as explained here: How to restore the system/boot drive letter in Windows .
  7. I deleted user account created during setup and created a new one.
  8. All problems solved.
share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .