Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Like many users with hybryd video (I have ATI and Intel on my laptop), i've tried to solve the problem by making proprietary drivers actually work, but failed at that (changing between GPUs causes mess in x-server configuration)

so, unable to tolerate all the fan noise and excessive heating, i've decided to just switch the ATI GPU off (not that I would really need it)

i've done that by editing /etc/rc.local file, i've added (as prompted) two lines before exit 0:

chown -R $USER:$USER /sys/kernel/debug
echo OFF > /sys/kernel/debug/vgaswitcheroo/switch

everything works great, even sensors command indicates the temperature of radeon PCI adapter as -128*C

the only issues is, that works only after a reboot. if I just close the lid and my laptop goes to sleep, whenever it wakes up radeon apater is back to life again at +38*C

not that it is as loud and problematic as it was before the rc.local fix, but the fan is really annoying.

so, the question is: are there any ways to keep radeon GPU switched off after waking up from sleep?

share|improve this question
    
Is the a reason you are not switching it off from the BIOS? –  terdon Feb 13 '13 at 12:35
    
the only thing I can do in BIOS is to choose between "dynamic" and 'fixed' options. "fixed" doesn't stop ATI GPU from overheating unless rc.local is being properly edited. –  user2057368 Feb 13 '13 at 12:38

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.