Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

For the longest time, I've been running XBMC v10, but wanting airplay capability, I updated to the latest stable version. Now my audio no longer works in XBMC. My system sound works, and other apps work as well, just not XBMC.

I've tried messing around with the settings in XBMC to no avail, restarting the app multiple times after changing something, all without success. I'm using an NVidia GeForce 9800 GT video card, which takes the S/PDIF output from the onboard sound, a RealTek device, and outputting over HDMI to my home theatre receiver.

As far as I can tell, XBMC kept all my previous settings (save for my theme), so it should have worked straight off the bat. Is there something I'm missing?

UPDATE: I've updated my video and chipset drivers to the latest and greatest, which hasn't solved the problem. I would have updated my audio driver, except I already have the latest one listed on my motherboard manufacturers website.

I've also done some more research, and apparently, the folks behind XBMC replaced the audio backend between my previous version and the current version. I'm thinking this is the probable cause of my issues.

share|improve this question
Have you confirmed that outside of XBMC, audio is still working flawlessly? This just confirms that the audio is in fact screwed up in XBMC specifically. – David Feb 13 '13 at 1:22
@David: Yes, I believe I said that in the question. Youtube TV with Firefox works fine. – MBraedley Feb 13 '13 at 1:23
Sorry about that @MBraedley. I was just glancing past your question while I was working and didn't notice it. I am going to ponder on you questions for a little bit. I will let you know if I think of anything. In theory it should still work... – David Feb 13 '13 at 2:27
up vote 0 down vote accepted

Wow, I feel like an idiot. The in app volume was turned down to about 25 percent, which was quiet enough that I couldn't hear anything through my home theatre speakers. I've programmed my remote with buttons for that function, but it didn't occur to me to check that the volume might be down.

It's either that or forcing it to switch devices and back (by plugging in a pair of headphones) did something that should have been automatic.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .