Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have the following network:

[Server]--------[CAT3560_1]---------P1--[CAT3560_2]-P23/P21------[PCs]

There is just one VLAN, and this is VLAN100.

Server and PCs are in the same network.

CAT3560_2 Port 1 has trunking enabled.

Until now I only configured CAT3560_2.

What I want is that every traffic on CAT3560_2 Port 23 is the highest priority and every traffic on CAT3560_2 Port 21 is the lowest priority. Which means, that if the two traffics would collide, the traffic from Port 21 gets thrown away.

I tried to set CoS values with the mls qos cos override command, but it didn't work.

Heres the config from CAT3560_2

Switch#sh run
Building configuration...

Current configuration : 3673 bytes
!
version 12.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Switch
!
boot-start-marker
boot-end-marker
!
!
!
!
no aaa new-model
system mtu routing 1998
authentication mac-move permit
ip subnet-zero
!
!
!
mls qos
!
crypto pki trustpoint TP-self-signed-3180391424
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-3180391424
 revocation-check none
 rsakeypair TP-self-signed-3180391424
!
!
crypto pki certificate chain TP-self-signed-3180391424
 certificate self-signed 01
  3082023F 308201A8 A0030201 02020101 300D0609 2A864886 F70D0101 04050030
  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
  69666963 6174652D 33313830 33393134 3234301E 170D3933 30333031 30303031
  32345A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D33 31383033
  39313432 3430819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
  8100BAEA BB0A5111 CB69854F 50FE404B 165C9CDB C6DC016E 6438D5E8 8438FD5C
  4EE66D88 953AF56B CEBCAC16 3E8B1E4B A0D0672E F75CE077 B6C08E6C 5780CE44
  A498CE7C 0B53E95B A7092165 0D6615D6 52BC627D 43D62E8E F02AA92A 9B8EE929
  1B2D7839 9EDE9A9A 20F3F8C0 252191F4 19A1600E 7A7CC3A0 539606D3 B08FD540
  7E6F0203 010001A3 67306530 0F060355 1D130101 FF040530 030101FF 30120603
  551D1104 0B300982 07537769 7463682E 301F0603 551D2304 18301680 1489EB1E
  A9C702D9 B2AA4334 C363388E 0A99B663 28301D06 03551D0E 04160414 89EB1EA9
  C702D9B2 AA4334C3 63388E0A 99B66328 300D0609 2A864886 F70D0101 04050003
  8181005D A034955B 716BCFB0 CF0F57E9 59F03ECD 2B28D911 2F3EBB5C 0A2676C1
  41B40EF1 B0FAD6CD C66A16E8 F68B0F51 4916B896 BCCC2318 F478889E 6F9629B6
  B42DF638 0F3F65ED 258EA7A3 309F7F71 70358C82 6E68F28E 87E4E4FF 7E447C5C
  22B70F6E 571C07BF 74B1EC69 F1A15182 60D283A6 4C833681 B2E41F33 065C0136 1FC7A4
  quit
!
!
!
spanning-tree mode pvst
spanning-tree etherchannel guard misconfig
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
!
!
interface FastEthernet0
 no ip address
 shutdown
!
interface GigabitEthernet0/1
 switchport trunk encapsulation dot1q
 switchport mode trunk
 speed 10
 srr-queue bandwidth limit 10
!
interface GigabitEthernet0/2
!
interface GigabitEthernet0/3
!
interface GigabitEthernet0/4
!
interface GigabitEthernet0/5
!
interface GigabitEthernet0/6
!
interface GigabitEthernet0/7
!
interface GigabitEthernet0/8
!
interface GigabitEthernet0/9
!
interface GigabitEthernet0/10
!
interface GigabitEthernet0/11
!
interface GigabitEthernet0/12
!
interface GigabitEthernet0/13
!
interface GigabitEthernet0/14
!
interface GigabitEthernet0/15
!
interface GigabitEthernet0/16
!
interface GigabitEthernet0/17
!
interface GigabitEthernet0/18
!
interface GigabitEthernet0/19
!
interface GigabitEthernet0/20
!
interface GigabitEthernet0/21
 switchport access vlan 10
 switchport mode access
 mls qos cos 4
 mls qos trust cos
!
interface GigabitEthernet0/22
!
interface GigabitEthernet0/23
 switchport access vlan 10
 switchport mode access
 mls qos cos 7
 mls qos trust cos
!
interface GigabitEthernet0/24
!
interface GigabitEthernet0/25
!
interface GigabitEthernet0/26
!
interface GigabitEthernet0/27
!
interface GigabitEthernet0/28
!
interface TenGigabitEthernet0/1
!
interface TenGigabitEthernet0/2
!
interface Vlan1
 no ip address
 shutdown
!
ip classless
ip http server
ip http secure-server
!
ip sla enable reaction-alerts
!
!
line con 0
line vty 0 4
 login
line vty 5 15
 login
!
!
monitor session 1 source interface Gi0/1
monitor session 1 destination interface Gi0/13 encapsulation replicate
end
share|improve this question
    
Where are your policy and class maps? –  onxx Mar 13 '13 at 20:42
add comment

1 Answer

In your config are you missing a policy and class map, and then need to apply it to the specified interfaces. It has the same defining principle as ACLS. Create the policy and then assign it.

This would be a basic example, was taken from explanation in the web link.

        dscp 56 = incoming packsts
        police defines rate limits

        acl 1
        permit x.x.x.x

        class-map test
        match access-group 1

        policy-map test
        class test
        ip dscp 56
        police 5000000 2000000 exceed-action drop



        int gix/x ingree traff
        service-policy input test

        intgx/x egress traff
        priority-queue 
        wrr-queue cos-map 4 6 7

In order to get a clear understanding of how QoS works you read this documentation from Cisco. Cisco C3560 QOS

  1. Cisco C3560 QOS. www.cisco.com March 13th, 2013. result of Google search Cisco 3560 QoS
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.