Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Most tutorials online show how to install PEAR by doing this:

sudo apt-get install php-pear

This installs version 1.6.1. It works great because it's super easy! My problem is that I want to install PHPUnit and it requires PEAR version 1.8.1 so my install of PHPUnit failed. So how do I install a newer version of PEAR on Ubuntu?

share|improve this question
up vote 77 down vote accepted

First, install PEAR.

sudo apt-get install php-pear

Next, tell PEAR to update its own channel.

sudo pear channel-update pear.php.net

Then, tell PEAR to upgrade itself to the newest version.

sudo pear upgrade-all

You should now have the newest version of PEAR installed.

To install PHPUnit, let PEAR know where to find PHPUnit.

sudo pear channel-discover pear.phpunit.de

Then install PHPUnit. (the -a makes sure all dependency packages are also installed)

sudo pear install -a phpunit/PHPUnit

Update:

According to the latest PHPUnit installation documentation, you can install PHPUnit with the following commands (make sure you have updated PEAR first):

sudo pear config-set auto_discover 1
sudo pear install pear.phpunit.de/PHPUnit
share|improve this answer
    
Incidentally it might be good to add apt-get install curl and sudo pecl install xdebug for code coverage – David Apr 18 '11 at 4:08
3  
actually, I just discovered that apt-get install php5-xdebug is the easiest. =] – Andrew Oct 4 '11 at 20:31
2  
I've been burned a few times in the version difference between what is in the public repo and what's on pear, last time was earlier this year ( 2011 ) where there was a regression in the Ubuntu repo. – David Oct 4 '11 at 21:18

Last versions of PhpUnit require ez/zeta components & symfony's YAML lib

sudo apt-get install php-pear
sudo pear channel-update pear.php.net
sudo pear upgrade-all
sudo pear channel-discover pear.phpunit.de
sudo pear channel-discover components.ez.no
sudo pear channel-discover pear.symfony-project.com
sudo pear install -a phpunit/PHPUnit

See the last updated installation tutorial here

share|improve this answer

If installation using above command failed, You might need to install Net_URL2-0.3.1 and then HTTP_Request2-2.0.0RC1 before installation of PHPUnit on Ubuntu. Find the latest version of the above packages and install them.

Example:

sudo apt-get install curl

sudo pear install pear/Net_URL2-0.3.1

sudo pear install pear/HTTP_Request2-2.0.0RC1

sudo pear install -a phpunit/PHPUnit

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .