Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm running the latest 64bit version of Miranda IM on Windows 8. Gtalk works perfectly fine for me except for file transfers, it says no compatible file transfer mechanism exists when I try sending a file to someone who's running the old desktop version of Gtalk. When they try to send me a file, it tells them that 'the other person may be using gmail'.

I created my Gtalk account using the built in function, and after checking, the parameters are just as specified in the Google talk help page.

The Miranda forums don't shed any light either..anyone know of a fix?

share|improve this question
    
Sounds like a problem with the Miranda software. You report this behavior as a bug. Of course the solution is don't use old unsupported software. –  Ramhound Feb 13 '13 at 13:04
    
my very first line says that I'm using the latest version. –  Rex Feb 14 '13 at 8:02
    
Except your friends are using "the old desktop version of Gtalk" which isn't really supported anymore. –  Ramhound Feb 14 '13 at 12:18
    
But file transfer works fine between users of the desktop client, they just stopped developing it after 2006. –  Rex Feb 15 '13 at 12:46
    
Clearly this problem is recent so it either can be solved by tweaking Miranda on your end or by having your friends migrate to Miranda or some other more recent desktop client on their end. This can't be solved on their end if they don't update. –  Ramhound Feb 15 '13 at 12:50

1 Answer 1

up vote 1 down vote accepted

Actually the clue is in the error message. For most connections, it won't be possible to set up a direct connection between two peers, even if you allow it (see screenshot below). One main reason would be NAT.

The solution is to use a bytestream proxy that both peers can use and configure Miranda for that. It is likely that your side is the failing one from what you describe. In general, of course, it could be that either or both sides fail. So looking at the other person's settings may be necessary.

Options dialog of Miranda IM

The second checked checkbox and the accompanying edit field are what you are looking for.

Also note: the bytestream proxies are services in the XMPP ("Jabber") sense, so the names, albeit appearing as DNS names, may not be entered in the DNS server, if you are connected to the Jabber server's domain that offers the bytestream proxy. The canonical name is usually proxy.domain-name, at least in OpenFire it used to be and ejabberd it is.


Edit:

where to find a bytestream proxy: From the Miranda main menu (the "crown") pick the protocol/account you configured. It should give you a popup menu with another submenu "Services" under which you find "Service Discovery". In there will it list available bytestream proxies for your service, if the server has been configured to advertise and provide this service. See the screenshot below.

Service Discovery in Miranda IM

The second to last shows the proxy service. Again, this has to be enabled on the server. And in addition Google - from my experience - does some things to complicate for example encrypted S2S connections, so I wouldn't be exactly surprised if some complications come up with the bytestream proxy as well. At least I couldn't see any offered services. Even though GTalk uses XMPP, they aren't completely following the standard as far as I understand.

share|improve this answer
    
So where do you find a bytestream proxy..and does the other person also need it? I'm the only one that's using Miranda among my friends. –  Rex Feb 14 '13 at 8:04
    
@Rex - Anyone not using Miranda won't be able to configure their end. So if there end is the problem then they are out of luck. The desktop client has not been supported for awhile now. –  Ramhound Feb 14 '13 at 12:17
    
@Ramhound: I don't know where you take this generalization from, but I cannot confirm this from experience. Running two Jabber servers myself (one corporate one private) I had to support people with numerous different clients already and most of them do provide options to configure this, not just Miranda IM. –  0xC0000022L Feb 14 '13 at 17:10
    
@Rex: amended my answer. –  0xC0000022L Feb 14 '13 at 17:18
    
@0xC0000022L - The only other client the author asked about was GTalk and it does not support doing this rom what I can tell. –  Ramhound Feb 14 '13 at 17:37

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.