Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

A network topology diagram is here:

enter image description here

I am able to establish a tunneling connection over OpenVPN from the PC to the OpenVPN server (icon is green). When I try to ping the Server, however, I get no response. I'm not a network guy, but my suspicion is that Server's responses are being routed out to the modem.

I have tried leaving the router un-modified and that doesn't work (as expected). I have tried adding variations of the static routing table entry shown in the diagram. I've tried it with Hops set to: 1, 3, and 4 and I've tried it with Gateway set as shown as well as 192.168.1.1. Why can't I ping Server?

EDIT: First, a correction. The connection is not using the tunneling interface like I thought. It's using the TAP interface.

I did tracert's from both ends and the results are interesting. On PC, tracert 192.168.1.100 gets nothing at all. On Server, tracert 192.168.2.104 gets nothing, but tracert 10.8.0.6 (IP assigned by OpenVPN) goes into a loop between 192.168.1.102 and 192.168.1.1.

EDIT: So, this nice guide seems to say that I should be using bridging instead of routing. I think I will investigate using this setup. I am curious though, I didn't configure a static route on each machine, but I configured a static route on the gateway (the wired router) to send VPN packets (subnet 10.8.0.x) to the VPN server. Why didn't that work?

share|improve this question
    
Your Server is outside of VPN, how are you supposed to ping it? –  Paul Feb 13 '13 at 15:55
    
There are a number of possible problems with this, the 2 most likely being a routing issue on the OpenVPN server or PC. Can you provide the result of traceroutes (with the VPN up) from PC to SERVER and Server to PC OpenVPN IP to narrow down the problem. (My gut feel is that OpenVPN server is not configured to forward packets. Also, your hypothosis is probably correct, I'd imagine you need a static route from Server to route 10.8.0.0 via OpenVPN server (under Linux route add -net 10.8.0.0/24 gw 192.168.1.102 on server) –  davidgo Feb 13 '13 at 18:58
    
tcpdump would help you here –  tictacbum Feb 15 '13 at 18:46
add comment

1 Answer

Check out this link that provides debugging for what appears to be the same issue.

http://openvpn.net/index.php/open-source/faq/77-server/285-everything-seems-to-be-configured-correctly-but-i-cant-ping-across-the-tunnel.html

share|improve this answer
    
This seemed to help others as well: forums.openvpn.net/topic7722.html –  Kurtymckurt Feb 15 '13 at 18:46
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.