Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've a ZenBook UX32VD laptop with a Intel i7-3537U CPU. I'm on ubuntu 12.10 (kernel 3.5.0-23-generic, xorg 1:7.7, nvidia-current 304.64 and gnome-shell 3.6.1). This laptop has a nVidia card with the optimus technology.

I've three monitors that i want to connect to my laptop. The laptop screen has a resolution of 1900x1080, i've a iiyama screen with a resolution of 1920x1200 and finaly a acer screen with a resolution of 1366x768.

My goal is to have the iiyama screen as primary, the laptop on left and the acer on the right.

When i connect all the monitors, gnome-shell blinks and finaly displays a black screen (on the 3 monitors) and shows only the mouse pointer (i can drag the mouse over the 3 monitors).

When i set a resolution of 1680x1050 for the iiyama screen, all is working fine... :( If i disable the Acer screen, then i can set the max resolution on both the laptop and the iiyama screen.

I've pasted the result of the command xrandr -q on this link: http://pastebin.com/i6J6maUP eDP1 is my laptopt integrated screen, HDMI1 the iiyama screen and the acer screen is VGA1. I don't know who is the DP1 disconnected screen.

Someone knows this problem? How can i debug it? I've no error in Xorg.log, nothing in syslog or in dmesg...

I've no easy way to do the test with Windows.. (i'm working with LVM and i don't want to break the system..)

share|improve this question

1 Answer 1

Gnome 3.x prior to 3.4 (I believe) had a limit on the MAXIMUM horizontal resolution it could handle (due to the hw acceleration required to run the Gnome desktop and how they ... did something) of 5000 pixels.

With all three of your monitors at full resolution you're at 5186 horizontal pixels.

Switching to a lower resolution on the Iiyama drops you to 4946. Below the 5000 pixel limit.

Gnome 3.6 has certainly fixed this and I believe 3.4 did as well.

Your only choices are :
1) upgrade to a newer Gnome release,
2) Use another non-gnome desktop.
3) Fall-back mode.

PS: I'm currently running a 5440 pixel desktop, so this HAS been fixed... but I can't find any reference to this absurd limit, though I do recall reading about it in the past year or so. I wasn't running three monitors then, though.

EDIT:
Well, I still can't find that reference. There is this: [live.gnome.org] (https://live.gnome.org/GnomeShell/FAQ#Why_GNOME_shell_works_with_my_video_card_with_one_monitor.2C_but_does_not_work_in_multihead_mode.3F) but that just refers to hardware limitations, and the 5000 pixel limit was a software/gnome limitation. It is possible this is what's happening, but I think it's that 5000 pixel limit I read about in gnome 3.0-3.2 (and maybe 3.4).

share|improve this answer
    
Hi! Thanks for your usefull answer! I've tested with fallback mode and all is working fine with this wm. You said that the problem has been certainly fixed with gnome 3.6, but i'm currently working with gnome-shell 3.6.1 :( You said that you're currently running a 5440 px desktop: which is your wm? –  rclsilver Feb 14 '13 at 8:25
    
I'm using Cinnamon on top of Gnome 3.6, but Gnome-Shell works too. I stumbled across a reference to the 5000px limit in gnome 3 last year but still can't find it. I suspect it's been updated and so simply isn't there anymore (except in archives). If you're on 3.6+ then you might simply be hitting the hardware limit for your GPU(s). All GPUs can only do HW acceleration to to a point (resolution wise). (cont) –  SuperMagic Feb 14 '13 at 20:59
    
You should look up the exact models of GPUs (using the Optimus feature sounds like it switches between two GPUs depending on needs, and with three monitors you might be using both GPUs simultaneously and one of them might not be able to drive the monitors plugged into it at full resolution. However, finding that information may not be easy. I can't find it for most desktop GPUs –  SuperMagic Feb 14 '13 at 21:00
    
I've already checked the specs of my graphics card. My laptop is provided with a Intel HD 4000 graphics card which can handle 3 displays with a resolution of 2560x1600... I tried to place a screen above of my iiyama (in display settings) and in this case, all is working fine.. i'll try with KDE with a "inline" layout. If it works, so my graphics card is definitely OK –  rclsilver Feb 15 '13 at 13:21
    
Cool. Post back with the KDE results.....Make sure desktop effects are on on all three monitors to get the right comparison (you already know non-accellerated linear layout works (fall-back mode)). –  SuperMagic Feb 15 '13 at 17:30

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.