Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I just tried updating the iPhone's firmware, and things went haywire.

iTunes informed the update had failed and linked me to iOS: Resolving update and restore alert messages.

The iPhone is stuck on the image from the top of that page.

I held down the sleep and home buttons until it turned off and turned it back on, and then went through the iPhone's 'restore' mode.

It then error'd again and I'm stuck back with the logos on the iPhone.

How do I to fix this?

share|improve this question

2 Answers 2

up vote 6 down vote accepted

I would definitly follow all directions on that page, they should help, If not I recommend taking it to the apple store, A bunch of people I know have been having weird problems with their iPhones. One took his into the apple store and got a completely new phone because of it.

share|improve this answer
2  
+1 Liked the part where you get your old phone replaced. –  Ganesh R. Oct 14 '09 at 5:10
1  
A friend of mine had a similar issue with his iPhone, Apple replaced it at no charge. –  Matt Haley Oct 14 '09 at 6:50
1  
I took it back to the Telstra shop (Australians will know what I'm talking about!) –  alex Oct 14 '09 at 10:32

I saw that screen the other day .. I was using my laptop unplugged and told it to go ahead with the latest iPhone software upgrade. It took a while, I wasn't paying attention, and BANG .. the laptop goes to sleep because it is out of juice. When I plugged it in it sat for a few minutes then asked if I wanted to restore. I did, and it worked.

I presume that you have followed the suggestions in the linked page, and that they haven't worked. The only other things I would try (before visiting the Genius Bar) are:

  1. Hard reset the iPhone (hold both buttons until the apple appears). This likely will not fix the problem, but will clear out any detritus.
  2. With iTunes running, connect the iPhone and let it sit a while.
  3. If iTunes recognizes the iPhone, try the restore option.

Good luck.

share|improve this answer
    
Thanks for the answer. I have tried hard resetting. iTunes does recognise the iPhone, but when I select 'restore' it goes through a few progress bars then errors again. –  alex Oct 14 '09 at 5:36

protected by Diago Dec 17 '10 at 12:03

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.