Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Before anyone tells me not to disable S.M.A.R.T I've confirmed in the BIOS that the drive is actually reporting it's okay. Windows is misreading whatever reports S.M.A.R.T. status.

I would like to know how to disable S.M.A.R.T. errors in Windows 7. I'm using the RTM version of Windows 7.

I know it's possible to disable the reporting in Windows XP and Vista I just don't remember how I did it.

share|improve this question

3 Answers 3

Most probably the problem is in the windows communications with the HD. Before disabling SMART reporting, I'd suggest checking to see if there are any new BIOS, HD driver or chipset driver updates for your computer.

Meanwhile, or if there are no updates, get also your own S.M.A.R.T. reporting tool and trust its results. GSmartControl is one such tool. Freeware and allows you to both check current status and perform any built-in tests supported by your HD. This is better than the BIOS page own ad-hoc reporting.

To actually disable SMART, well you do it on the BIOS. You cannot disable it in Windows. I'm not sure what you mean by forgetting how you disabled the reporting in the past. It's possible you know something I don't, but I never heard of anyone able to disable S.M.A.R.T error reporting on windows.

share|improve this answer
    
The BIOS has built in hard drive testing. It reports the drive is fine. Windows is reading is as if the drive is failing. I can't disable S.M.A.R.T. in the bios. –  epochwolf Oct 14 '09 at 21:43
up vote 5 down vote accepted

Solution: After choosing "Tell me later" on the error popup several times I was presented with a third option to ignore the problem.

I choose the option to ignore and the popup hasn't appeared since. A little research shows that this behavior is also present in Vista not just Windows 7.

share|improve this answer
    
+1 Well there you go!. Glad I learned something new :) You should set your own answer as the accepted one if indeed you feel comfortable with your findings. I'm personally very suspicious of any SMART errors, so I wouldn't be so dismissive without at least having tried another tool to test the disk. Meanwhile this behavior is even present on Windows XP and Linux. It's not uncommon, but neither it is unheard of. You should keep an eye on new drivers/flash for your BIOS, controller and chipset. That's where these problems are finally fixed. –  A Dwarf Oct 14 '09 at 22:13
    
I can't accept my answer for another 12 hours :) I'm waiting. –  epochwolf Oct 15 '09 at 17:37
    
Is there a way to reverse the "ignore", by any chance? –  rakslice Mar 18 at 1:01

I know this thread is a bit old, but perhaps someone will still find this useful. I chose "Tell me later" at least a couple dozen times and never got the third option to ignore the problem. I kept getting this popup even after disabling SMART checking in the BIOS, so yes, Windows can do its own check separate from the BIOS. Leaving aside arguments for why you shouldn't disable SMART checking, here's what to do (Windows 7):

Start Menu -> All Programs -> Accessories -> System Tools -> Task Scheduler In Task Scheduler, expand "Task Scheduler Library" in the upper left corner. Next, expand "Microsoft", then "Windows". Select "DiskDiagnostic" from the list. You should now see two items in the top middle frame. The second item, "Microsoft-Windows-DiskDiagnosticResolver", is responsible for reporting drive errors. You can either disable it or configure it to run less frequently than every logon.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.