Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a wireless network at home to which my laptop connects without any problems, same for the one at my parents and grandparents place.

The problem is the wifi at my school which requires me to write my username and password every single time I logon. There is a checkbox mark "remember password and username", but it is greyed out (disabled). How do I get it to show?

share|improve this question
up vote 2 down vote accepted

It turned out that I can solve this problem by going to control panel -> network and internet -> connect to a network then right click the network and select properties then make sure the box with the label "Cache user information for subsequent connections to this network"

This morning I didn't have to log in.

share|improve this answer
I don't have any such check box, it seems, and I'm running Windows 7. Which Windows OS are you using? – HelloGoodbye Mar 18 '14 at 14:15

If the options are greyed out at school but not at home then it's something the school is setting at their end to prevent automatic logons. I can see why they wouldn't want people to automatically connect - after all it is their bandwidth you're using.

Because it's set by their server it's not something you can override.

share|improve this answer
They properly would, but I want to override them. – tomjen Oct 14 '09 at 8:24
This doesn't sound correct to me. In order for the school to block him from connecting to their network automatically, they would have to have admin access to disable that on his machine, which would be a violation of security and privacy on his machine. This sounds more like a Windows setting blocking him from maintaining passwords for wireless connections. – Tom Oct 14 '09 at 16:02
@Tom: He can maintain passwords for all wireless connections just fine, it's only the school's connection that's blocking it. – Will Eddins Oct 14 '09 at 17:19

Depending on your browser, if you enable the password manager feature it may offer to remember the school login for you, thus preventing you from typing it every time.

share|improve this answer


SetTitleMatchMode, 2
    ifWinActive, Paint
    	msgbox "paint is open"
    goto begin

Will check to see if paint is active, and if it is tell you so in a message box, then exit. What you'd do here is tell it to send the correct keystrokes to input the username then password as soon as the dialogue came up. Not quite automatic, but not going to be stopped by some silly greyed out checkbox :)

(I can help with the input, but not if I don't know enough information. What kind of box is it, for example? Is one box automatically highlighted, and can you tab between username, password, and ok?)

share|improve this answer

There is an option to have Microsoft set the password for you. If you uncheck this box, it should enable you to enter your own username/password.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .