Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a pretty bad amd e300 cpu. Whenever I am on battery and on balanced plan, cpu-z reports my frequency to be 798 mhz (in all conditions (full load etc)). However, in the processor power management/processor state, the max processor state is 100% or the full 1.3 ghz. The computer is not hot whatsoever. The only way I can fix it is if I use high performance. However the settings I customized in both high performance and balanced are exactly the same. My system is windows 7 64 bit and this problem is in windows 8 as well. My question is why does the balanced power plan automatically underclock the cpu even if I set it not to in the settings?

Edit: However, this does not happen on my other laptop, it has an amd m520 2.3 ghz and does not underclock to 800mhz.

share|improve this question
    
What's the question? –  Petr Abdulin Feb 14 '13 at 5:22
    
Fixed, i was in a rush :D –  agz Feb 14 '13 at 6:16

4 Answers 4

up vote 1 down vote accepted

The system cooling policy could be the problem. If the cooling policy is set to passive while on battery, your CPU clock rate could be limited to reduce heat and keep the fan running at a lower speed, since higher clock rates translate to higher heat levels and a greater need for cooling.

share|improve this answer
    
Wow, the simplest answer is correct. –  agz Feb 16 '13 at 0:15
    
Could you probably explain why this is the case. Passive cooling means that the fans are not in use, so windows assumes that only the lowest frequency is safe? –  agz Feb 16 '13 at 0:16
    
The idea here is to keep heat output to a minimum, so that the fans don't need to run as fast as they would otherwise need to. A CPU at a higher clock rate generates more heat than one that runs at a lower clock rate, so limiting the clock rate keeps the need for cooling to a minimum. –  DragonLord Feb 16 '13 at 0:38
    
Ok great, so basically windows will not allow the cpu frequency to go up if the power plan is set to passive cooling? –  agz Feb 16 '13 at 0:56
    
Exactly. It's to allow the fans to stay off or run at a minimum speed. –  DragonLord Feb 16 '13 at 1:08

Possible solution

A Since it gives you the speed you want, I just wanted to float the idea that you could use the High Performance plan, and adjust it to your needs.

Possible solution B

There are a lot of hidden power options that you can't see in the Power Options control panel.

I am guessing that the built in profiles toggle some of these on and off, and that one or more of them is causes the behavior you are experiencing.

You can view a list of the hidden settings here (this is for Windows 7, so there may be new ones in Windows 8).

From the command line, their usage is: Powercfg -setacvalueindex scheme_current sub_processor [GUID] [VALUE]

And finally, to activate the plan: Powercfg -setactive scheme_current

Here are some interesting ones:

Processor Performance Increase Policy
Descripion: Specifies how a target performance state is selected if the current processor utilization is above the value of the Processor Performance Increase Threshold setting.
GUID: 465e1f50-b610-473a-ab58-00d1077dc418
Options: 0, 1, 2 - (Ideal, Single, Rocket)

Processor Performance Boost Policy
Descroption: Configures the processor performance boost policy. The behavior of this setting can differ between processor vendors and specific processor models. The processor vendor should be consulted before changing the value of this setting.
GUID: 45bcc044-d885-43e2-8605-ee0ec6e96b59
Options: 0-100 (percentage)

Allow Throttle States
Description: Specifies that the performance state algorithm can use any ACPI throttle states (T-states) that the system supports.
GUID: 3b04d4fd-1cc7-4f23-ab1c-d1337819c4bb
Options: 0,1 (No, Yes)

To understand the options in details and dependencies on other hidden options, see the doc or this image. Hidden power options

There's is also a document written for Server 2008 R2 which might have additional information, but I'm having trouble downloading more than the first 13 pages.

share|improve this answer

Even though you set max frequency to 100%, Windows didn't think that you really need those 100% then running on a battery to achieve current (balanced) power plan main goal. And as you can expect, you get it in max. performance plan.

So, the plan differences in not only in actual values. Even then you are creating your custom power plan you must select one of the predefined plans to be base for your plan, thus inheriting it's core behaviour.

share|improve this answer
    
However, this does not happen on my other laptop, it has an amd m520 2.3 ghz and does not underclock to 800mhz. –  agz Feb 14 '13 at 7:00
    
Then it's either 1) the power plans are different (you need do а doublecheck), or 2) Windows is fine on giving 100% percent on that, other, laptop. –  Petr Abdulin Feb 14 '13 at 7:56

Possible solution C

Try Rightmark PPM Panel. Both x86/x64 versions are available.

It does exactly the same things like Solution B above but using GUI-based panel. Of couse it can do a bit more. Just follow the link and watch readme text.

share|improve this answer
    
Adding some detail of why this is a solution would improve the answer. –  Dave M May 11 at 23:10
    
Why deface / delete your answer? It needed details of what the link(the link you provided in your original answer) does to solve the question. –  Carl B May 12 at 3:35
    
forget. I do not wish to help aggressive people those first shoot newcomer then ask. –  constm May 12 at 6:19
1  
@constm there's no shooting. You've been told how your answer can be made better, but you choose to ignore. Please don't deface your answers –  Sathya May 12 at 12:04

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.