Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I own a Lenovo G530 which is running Window XP Service Pack 3. I have run into some problem which concerns the USB ports. Yesterday, I inserted a USB flash drive (pen drive) into one of the port. Since then, the My Computer page fails to load. A flash light icon appears and keeps searching for drivers and folders forever. The drivers themselves are accessible through the command prompt or through the Run interface.

After this problem occurred, I tried to shut-down the system but it hung on Saving Your Settings. I did force shutdown through the power button. After re-starting the system, the problem persists. My Computer view is stuck in the scan phase. Also, I am unable to use my USB internet data card.

How can make my computer functional again? Please advice.

EDIT:

One of the event log errors:

The device 'JMB38X SD/MMC Host Controller' 
(PCI\VEN_197B&DEV_2382&SUBSYS_3D9B17AA&REV_00\4&1a9c2d41&0&00E0)
disappeared from the system without first being prepared for removal.
share|improve this question
    
If you remove this device does your computer function correctly? If that is the case then the device is broken. If this problems happens on every port then the device is broken. –  Ramhound Feb 14 '13 at 12:53
    
@Ramhound No, I have removed the USB pen drive all together, but still the My Computer and shutdown issue persists. –  Rickesh John Feb 14 '13 at 13:02
    
Does the problem exist in Safe Mode? –  Ramhound Feb 14 '13 at 13:10
    
Haven't tried it yet... I will an inform you accordingly. Thx –  Rickesh John Feb 14 '13 at 13:27
    
@Ramhound My system seems to be working fine while in Safe Mode. But I found a lot of irregularities with the way the OS is loading. –  Rickesh John Feb 15 '13 at 5:04

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.