Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Not knowing that this is a bad mistake — or maybe a massive bug in Windows 8 — I shared my complete user folder using Home Group on Windows 8 Pro x64. This changed the permissions for C:\Users\<username>\AppData and as a consequence of that, all Windows 8 apps failed. If I try to start one of them now, the full-screen app icon shows up for a couple of seconds followed by a force-close of the app.

I did some research and found that my sharing of the user folder apparently caused this problem. I also found that adding specific permissions for ALL_APPLICATION_PACKAGES for the folder C:\Users\<username>\AppData\Local\Microsoft\Windows\WER and a .dat file in a "Temporary Internet Files" folder should fix it, but it didn't, just like issuing sfc /scannow.

As I'm really not too keen on reinstalling my machine, do you have any advice on how to fix the permissions problem to make the apps work again?

share|improve this question
    
Did you try just leaving the Home Group in question? –  Ramhound Feb 14 '13 at 12:57
    
Yes, I cancelled the share some minutes after creating it. I told Win8 to restore permissions, but it still killed my apps. I'm stil in the home group, but leaving it wouldn't restore the permissions for AppData because the share is turned off already. –  iYassin Feb 14 '13 at 14:00
    
So you have not tried to leave and delete the home group? Can you try that? –  Ramhound Feb 14 '13 at 14:32
    
Alright, just tried it: I left the home group and rebooted - the apps still crash on launch. Is there any error log I could post here to help finding the issue? –  iYassin Feb 14 '13 at 14:42
    
I am sure there is an error log, try the event viewer, thats where most all crashes caused by Windows itself would end up. I will get back with you later today with a possible solution. –  Ramhound Feb 14 '13 at 15:06
show 1 more comment

2 Answers

Okay, I checked the error log. The only thing I can find is

Die App „microsoft.windowscommunicationsapps_8wekyb3d8bbwe!Microsoft.WindowsLive.Mail“ wurde nicht innerhalb der vorgesehenen Zeit gestartet.

In English:

The app „microsoft.windowscommunicationsapps_8wekyb3d8bbwe!Microsoft.WindowsLive.Mail“ did not launch within its allotted time.

share|improve this answer
add comment

I faced the same problem probably caused by sharing my user files. While not having a real solution (call it a work-around), you may try to log-into (or first create) another user account on the same system, where the (Metro) apps will eventually work. If this works for you (as it did in my case), you may dig into the differences of the two user accounts or just move your work to the new account and let the old account gracefully die.

share|improve this answer
    
Works for me, too. Is there any way to port application settings (Office, PS Lightroom etc.) to another user? Or is this just like moving to a new computer? –  iYassin Feb 20 '13 at 18:19
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.