Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

This question already has an answer here:

I was copying some files over an RDP session earlier, and all working fine.

Now, all of a sudden, the "Copy" and "Paste" functions to and from the RDP session have simply stopped working! If I "copy" a file to my local clipboard, then go into the RDP session, the "Paste" context menu appears greyed out. Same in the reverse direction.

I didn't do anything to change the configuration of my RDP session! I have tried closing and reopening the session, to no avail!

Local: Windows 7 x64 Pro

Remote: Windows Server 2008 R2 Enterprise

Any other ideas?

share|improve this question
add comment

marked as duplicate by Dave M, wizlog, 8088, Dennis, Nifle Feb 14 '13 at 19:59

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

1 Answer

up vote 6 down vote accepted

Can't copy and paste in Remote Desktop session

Even when you have the "Clipboard" option enabled, you may still have problems!

If that's the case, use Task Manager to kill and restart the rdpclip.exe process on local and remote machines.

More details on this blog post

The only way I really knew to fix the clipboard transfer was to close my session and restart it. That meant closing the tools I was using like Visual Studio, Management Studio and the other ancillary processes I have running as I work and then restarting all of it just to restore the clipboard. But today I found a good link on the Terminal Services Blog explaining that what is really happening. The clipboard viewer chain is somehow becoming unresponsive on the local or remote system and events on the clipboards are not being relayed between systems. It is not necessarily a lock being put in place but some sort of failed data transmission. It then goes on to explain the 2 steps you can take to restore the clipboard without restarting your session.

Use Task Manager to kill the rdpclip.exe process
Run rdpclip.exe to restart it

… and a pretty ridculous "explanation" from Microsoft.

share|improve this answer
    
Thank you! That worked! –  Shaul Feb 14 '13 at 15:18
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.