Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I upgraded my PC from 4 GB of RAM up to 24 GB (the maximum amount that my motherboard supports). I also bought a new case and re-cabled everything in order to move everything to the new case.

After that not a single of the OSes I have installed on several hard disks freezes during boot up - windows xp, windows 7 and fedora Linux 16. They all go past the POST and I can also see the loading screens of Win XP and Win 7.

Is the problem related to the amount of RAM I have installed in the machine or simply the re-cabling?

share|improve this question
The system gets past POST, so we are past BIOS error beeps. – Hennes Feb 14 '13 at 15:32
So does your system freeze when running all those operating systems? Your question is not clear about that. I assume these are fresh installations. – Ramhound Feb 14 '13 at 16:08
No these are not fresh, they are the old installations which i used before upgrading the RAM. The Winows Systems freez on the Loading screen (the progress bar on win xp and the glowing windows logo on win 7). I reinstalled the windows 7 drive and only plugged it in the MoBo but after the sucessfull install the same problem occured. What kind of mappings do windows hold for the installation drives? – Konstantin Boyanov Feb 15 '13 at 10:06

A few solutions to common problems:

  1. Make sure that everything is plugged in all the way.
  2. Ensure everything is plugged in where it belongs.

Take out a stick of RAM, does anyting change?

share|improve this answer

The quickest test is to remove some of the RAM, however it is more likely that you changed some of the drives cables and that the drives now appear in a different order.

As to the max RAM:

  • Windows XP is normally limited to 4 GB. It will boot fine if you have more memory. It will just not use it. (Exception: If you enable PEA or if you have the very rare XP-64bit).
  • Windows 7: If you have the 32 bit version it will also work, but only use up to 4 GB. There is no PEA option anymore. If you use the normal 64 bit version of win 7 then supports varies with the windows version. ( Starter: 8 GB / Home Basic: 8 GB / Home Premium: 16 GB / Professional: 192 GB / Enterprise: 192 GB / Ultimate: 192 GB )
  • I am assuming your Fedora installation is 64 bit (if not why?). It should not have any problems with the memory at all. If you happen to have an ancient 32 bit installation of Fedora then it should work fine, allowing up to 4 GB with PEA turned off, or 64 GB with PEA turned on). It should also display how much RAM it is using during boot.

As to the drive order:

Try booting Fedora in single user mode.

  • t the GRUB splash screen at boot time, press any key to enter the GRUB interactive menu.
  • Select Fedora with the version of the kernel that you wish to boot and type a to append the line.
  • Go to the end of the line and type single as a separate word (press the Spacebar and then type single). Press Enter to exit edit mode.

If that works try mounting drives. Changes are that whatever partition was on /dev/sda2 is now at /dev/sdb2 or vice versa. That will confirm that some cables got reversed.

Do not try try to fix it here unless you want to change the setup for every OS. Instead correct the cabling.

share|improve this answer
I will try rebooting in single user mode, and yes it is a 64 bit system :) thanks for the grub magic! – Konstantin Boyanov Feb 15 '13 at 10:07

In my experience, Windows often freezes at startup when something related to the hard drives and controller was changed. I suggest that you check if you connected the hard drives in the same way as before if they are IDE disks, and check in the BIOS setup that the controller is set correctly. Have you tried booting into safe mode?

share|improve this answer
Yes, I tried to boot in safe mode but Windows forze again during booting. Actually only one of the disks is an IDE hard disk, the one with windows XP, and it is connected to the only IDE port of the MoBo, so no changes there for sure :) I will check the cabling of the other hard drives. – Konstantin Boyanov Feb 14 '13 at 17:46
You can also try to connect only one drive at a time – Pincopallino Feb 14 '13 at 18:04

Well, here are my latest findings:

  • I tried several differend installation media for windows 7 and the installation went fine, only after installing MoBo / graphics drivers windows froze on login screen

  • I also tried windows xp install, everything fine, graphics drivers work, but after install of MoBo drivers no USB was usable (windows still running "flawlessly" though)

  • both installs were done on single attached disk with 4 GB of RAM (1 module attached to the MoBo)

  • before the windows xp install i saw in the BIOS settings that the MoBo was set up for 600 MHz 1600 RAM settings, and changed it to 557 MHz / 1066, what actually from the RAM modules supported is

  • I then installed a Fedora 16 on the same hard drive with all the memory and everything works just fine

Now I have two suggestions: either my mobo is damaged in some way, or the windows OS is for the recycle bin (sorry for the harsh suggestion ;)

Any thoughts?

share|improve this answer

I found it. Graphics gard was in "worng" slot (closest to the CPU, PCIE1 according to the manual). When I put it in the other PCI Express slot everything works like a charm (PCIE3 slot according to manual). I am not sure, could it be that my motherboard is damaged or all this is because of faulty CMOS / BIOS settings?

Anyway thanks for all the help and suggestions!

Cheers, Konstantin

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .