Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I just installed Ubuntu 12.10 on my ThinkPad T420s (no other operating system installed), and it is working. But there is a small thing which I just don't like... Everytime I shutdown and reboot, it's not automatically booting to GRUB. Insted you first see how the laptop tries to receive a image over the network. If i abort this attempt wich Esc or Ctrl+C it goes to a blue screen with two tabs (boot menu and application menu). On this boot menu I can choose between "Ubuntu", "ATAPI CD0...", "ATA HDD0...." and "PCI LAN...". If I choose Ubuntu, GRUB and Ubuntu boots.

I have already tried to install Ubuntu 3 times, every time with this same strange result. Can anybody tell me what's wrong here? Is it any configuration in BIOS I cannot find?

share|improve this question
3  
Try accessing the BIOS setup program during the very first seconds the computer starts up (different BIOS manufacturers use different buttons for this: could be Delete, or F1, or F2, or F12 or [...]. Usually it says which one somewhere on the first screen that flashes in the boot process). See if you can find a setting that gives the default booting device order. Perhaps network boot is the primary choice. In that case: move that option out of the way for preference of HDD boot. –  Daniel Andersson Feb 14 '13 at 16:58
    
I have already looked for that, the first entry in the boot order is "ubuntu". It's kinda strange, since i thought there may only be hardware options... –  Daniel Rotter Feb 15 '13 at 21:45
1  
I suspect @Daniel Andersson is correct. I wonder if the confusion is coming in with your understanding of the boot process. First the BIOS boots, then the OS. The BIOS determines the order of boot devices - in this case its doing a Network/PXE boot attempt first - this needs to be disabled/reordered to boot the appropriate disk - and is done in the BIOS, NOT the OS. If you are seeing "Boot Ubuntu" this means the bios has finished booting and the system has moved on to the hard disk to look at what the hard disk thinks should be booted. –  davidgo Mar 1 '13 at 23:36
    
I know this, and the network device is NOT the first in the boot order, it's ubuntu... –  Daniel Rotter Mar 5 '13 at 7:56
add comment

3 Answers

You can change your device boot order in the BIOS, as suggested by Daniel Andersson.

For the Thinkpad 420s, after either a cold boot or warm restart you will need to hit F1 as soon as you see the thinkpad logo appear (F1, not the blue ThinkVantage button). Act quickly, or the opportunity will slip by!

ThinkPad-Boot-Logo

The BIOS Setup screen will have "Thinkpad Setup" at the top, with blue and black text on a gray background. Navigation is generally done with the arrow keys. Use the right-arrow key to step over to the "Startup" menu. The "Boot" item is the first item in that menu, so it should already be highlighted:

Thinkpad BIOS Setup

Hit Enter and it will bring up the boot order menu. Use the up and down arrow keys to navigate to your network boot device ("PCI LAN IBA GE Slot 00C8 v1366"), and then use the minus ('-') key to move network booting lower in the boot order, after your hard disk. When you are done in Setup, use F10 to Save and Exit.

Your next reboot should then find the hard disk first, and not attempt to boot from network.

share|improve this answer
    
First I have to press the Thinkvantage Button and then F1 to load the BIOS, and secondly the network boot device is behind the others... –  Daniel Rotter Mar 5 '13 at 7:58
add comment

Just disable network booting in the BIOS. And change the device boot order to have "ubuntu" at the top.

Don't switch to "legacy only" booting, you have an uefi install of ubuntu (most probably, anyways).

share|improve this answer
    
I already have ubuntu on the top, but i cannot find the option to turn off network booting... –  Daniel Rotter Mar 5 '13 at 7:51
    
Please try setting "UEFI/Legacy Boot" to "UEFI Only". –  Fred Mar 6 '13 at 12:33
    
Done that, no network boot anymore, but still the second boot screen with ubuntu on top... –  Daniel Rotter Mar 10 '13 at 19:46
add comment

Based on your reply to Daniels comment, it sounds like you should try disabling UEFI boot in the bios. Use legacy instead. That might give you the boot menu you are used to seeing.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.