Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've setup conky on my laptop installation of linux mint 14 (cinnamon), conky works except for the font transparency. I'm using:

xftalpha 0.5

in .conkyrc. But whichever value I use, the transparency doesn't change. I've also tried changing the own_window_type. Doesn't make any difference unfortunately. Other people with similar setups report that it works for them. Can anyone guide to where the problem is?

I guess I shouldn't post my complete conky configuration, it's maybe a little too much. But the most important parts are:

xftfont sans:size=10
use_xft yes
xftalpha 0.5
update_interval 1.0
own_window yes
own_window_transparent yes
own_window_hints undecorated,below,sticky,skip_taskbar,skip_pager
own_window_type desktop
double_buffer yes
no_buffers yes
share|improve this question
    
Has it got something to do with my theme settings, or did I disable compositing in some way? Because my transition effects still show (switching between workspaces etc.).. –  user119287 Feb 14 '13 at 18:59
    
Also, conky disappears when I minimize windows, or press Ctrl + Alt + D. –  user119287 Feb 14 '13 at 19:09
    
@slm, It's the latest version from the mint 14 software manager. So I'd say 1.9.0 –  user119287 Feb 20 '13 at 11:30
    
So the window is transparent, but the fonts are not then, correct? –  slm Feb 20 '13 at 14:14
    
@slm, yeah that's right –  user119287 Feb 22 '13 at 9:13

1 Answer 1

up vote 1 down vote accepted

First make sure you are not using any ${font} or ${color} commands in the TEXT section of your .conkyrc. The transparency seems to break if you specify font options in any way other than the xft commands in the options section. You also need to specify the default color and a few more options, try this:

alignment top_right
update_interval 1.0
default_color 000000
default_outline_color 000000
default_shade_color 000000
own_window_argb_visual yes
own_window_argb_value 50
own_window yes
own_window_transparent yes
own_window_hints undecorated,below,sticky,skip_taskbar,skip_pager
own_window_type desktop
use_xft yes
xftfont sans:size=60
xftalpha 0.2
double_buffer yes
no_buffers yes

TEXT
THIS IS TRANSPARENT!
share|improve this answer
    
Thanks for the answer, the code you posted works. What's weird though is that it doesn't work for the color I would like to use (pure white, #FFFFFF). Any ideas why that is? –  user119287 Feb 22 '13 at 18:38
    
Also, from your answer I deduce that with this solution it isn´t possible to use mutiple font sizes (with transparency)? –  user119287 Feb 22 '13 at 19:00
    
@samuel i couldn't get it to work with white no. Same goes for font sizes, i think it is because conky can either use the xft commands or the conky font commands. I will try and find the thread i read this in. –  terdon Feb 22 '13 at 19:18
    
@Samuel this post is where I got the idea to remove the ${font} commands. –  terdon Feb 23 '13 at 10:01

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.