Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have an HP Pavilion G7-1310-US laptop running Ubuntu 12.04. I also have a wireless router at my home through which I connect my laptop and other devices to the Internet.

Recently, I have experienced a weird problem. If I connect my laptop to the wireless router, my other devices' connection speed drops from 30 MBPS to ~2 MBPS. I tested this by connecting my laptop to the network with a wired connection (and disabling wireless on the laptop.) If my laptop uses a wired connection, my other devices get proper speed (almost 30 MBPS).

What could be causing this?

share|improve this question
    
A very interesting problem. Does this occur equally if your G7-1310 is very close to the router, and what model is your router ? –  davidgo Feb 15 '13 at 4:50
    
Yes, It does. I am using Medialink's MWN-WAPR150N Wireless-N Broadband Router. –  J Modi Feb 15 '13 at 20:57
    
I have had a look at the specs and can't find anything obvious, save as to note it is a single channel router. The only thing I can think of is maybe your laptop is pushing a lot of traffic/packets causing everything else to get confused. [ Do you run any P2P on it ? ] –  davidgo Feb 16 '13 at 1:54
    
Hi David, I just use it to connect to my school computer. I don't download any other stuff. So you can think of that as a normal home laptop. –  J Modi Feb 16 '13 at 1:56
    
Can't really help then. I did find an article (itworld.com/networking/276200/…) which suggests it could be noise from your computer, but I've never seen what you describe before. Updating firware is a good idea. –  davidgo Feb 16 '13 at 5:53
show 1 more comment

3 Answers

up vote 2 down vote accepted

I have fixed this issue for my Ubuntu 12.04 by disabling additional wireless drivers. Applications -> System Settings -> Additional Drivers -> Broadcom STA proprietary wireless driver.

share|improve this answer
    
This solves an issue that has been affecting me for a long time. Any time my DELL Latitude laptop with Ubuntu 13.04 was on, all other wireless devices in my network lost connection. Disabling this propietary driver solved the issue. The instructions that worked for me in 13.04 are here: ubuntuforums.org/showthread.php?t=1997880 Thank you very much! –  Sergio Nov 5 '13 at 16:06
add comment

Try to restore the default settings of the router.
If that does not help then try to update the firmware to v11.8.

share|improve this answer
    
Which firmware are you talking about ? –  J Modi Feb 16 '13 at 1:56
    
@JModi Of the router. –  Hashirama Senju Feb 16 '13 at 10:49
add comment

I'm new to Ubuntu, and I`ve had the same problem with my Toshiba L675. Everything worked great (two cell phones, HP latpop and even Toshiba L675) when Toshiba was running on battery. When I plug-in my Toshiba laptop, connection on other devices goes down from 12Mb/s to 1, maybe 2. The only difference is that, when Toshiba L675 was running on battery, when I type

sudo iwconfig

I see among other things Power Management:on. On the other hand, when it's plugged-in it turns off the power management and everything works fine. Turning power management on manually sudo iwconfig eth1 power on did the trick for me at first, but I did some more digging, and I found that I had Additional driver installed for my wireless card. When I`ve deactivated it everything went to normal. I hope this helps, 'cause it was very frustrating for me.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.