Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I recently formatted my hard drive, and right now there's not much on here except a clean Windows 7 install and the most recent version of Vim for Windows. I told Vim to install its own context menu, so I can right click files and tell Windows to edit them with Vim.

Not only is this feature absent much (not all) of the time, so too is the "open with" option a lot of the time.

How can I get both of these options to show up consistently in the context menu?

share|improve this question
    
Have you tried first left-clicking inside the directory in Explorer? Sometimes I don't have the option, but it will show up if I click on a file (any file) inside the directory first. –  Ryan Feb 15 '13 at 1:52
    
If I remember correctly, you can get the 'open with...' option if you hold SHIFT while right-clicking. But there's an answer below giving some registry keys to tweak, perhaps that'll be better. –  lornix Jul 22 '13 at 13:54
add comment

1 Answer

I believe this is what you'll need

[HKEY_CLASSES_ROOT\*\shell\vim]
@="Open with Vim"
[HKEY_CLASSES_ROOT\*\shell\vim\command]
@="LOCATION_OF_YOUR_vim.exe_HERE '%1'"
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.