Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm using iTerm2 and tmux (from homebrew) on a Mac. I have set -g mode-mouse on in my tmux.conf. When I scroll up I am automatically put into copy mode but I am looking for a way to be able to scroll normally, without going into copy mode. I don't like the scrolling and most of the time I am not intending to copy anything anyway.

share|improve this question
    
See this question for superuser.com/q/209437/138254 options –  Brad Patton Feb 14 '13 at 21:05

1 Answer 1

As of tmux 1.8, it offers special integration with iTerm2. All you need to do is start a new tmux session with

tmux -CC

Then simply re-attach with

tmux -CC attach

Once started this way, it will look entirely native and scrolling will work as usual.

Official iTerm2 + tmux integration page details the use. Note that the information is a bit stale, as of tmux 1.8 this support is builtin so no need to build a custom tmux version.

tmux man page provides more information on the -CC flag, search for "control mode".

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.