Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a server application in linux that connects to port 443 to send HTTPS messages using SSL. When I run this code on my home linux box these connections go through instantly, but when I run this same code on my rackspace linux box the connection takes 20-30 seconds to go through.

I have verified that port 443 is allowed in ufw. Does anyone have any ideas as to what may be hampering with my HTTPS connections?

Thank you in advance.

share|improve this question

Its difficult without more information, but have a look at DNS. (IE work out if the problem is related to the server trying to resolve hostnames and then fix that problem - presumably by removing this dependency, and also ensuring DNS works quickly from the server).

One thing which would help is to do a tcpdump on your traffic to see where this problem is occuring, and if it is start to slow but then comes down quickly its probably DNS. (And if it starts quickly and then drops to a crawl it might be an MTU issue, but thats unlikely).

You should also do some connectivity transfers to and from the server (if you havn't already) to make sure there is not a routing or bandwidth limiting issue, although this is less likely.

share|improve this answer
if i do nslookup and it comes back fast does that mean my DNS is okay? – Josh Brittain Feb 15 '13 at 5:29
Sorry I meant time nslookup – Josh Brittain Feb 15 '13 at 5:50
Sorry, not enough information. Where did you do the nslookup from ? What happens if you do an nslookup on your IP address ? (from the server). – davidgo Feb 15 '13 at 5:59
While on my server if I lookup the servers ip address I get server cant find NXDOMAIN which is my ip address in reverse. I'm assuming it is trying to do a RDNS lookup? While on the server if I do an nslookup on my home ip address it works fine. – Josh Brittain Feb 15 '13 at 6:19
I'd be surprised if that is your problem, but (if its not there already) try adding "" to your hosts file). – davidgo Feb 15 '13 at 7:19

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .