Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am plagued by random behavior from IE8. Increasingly often I click a link in an email and the new tab appears to hang. I usually see the spinning circle that suggests the tab is loading. I somtimes see the title appear, then I can wait forever. Whilst I am waiting I can return to the email, copy the link, paste it into a new tab and SOMTIMES the page will come straight up. Somtimes it won't.

A bit of googling suggested it was the pop-up blocker (Tools | Popup Blocker) so I turned that off. It seemed to get better for a while, but now it's a pain again.

I see the same behaviour if I Wheel click (open in a new tab) a link on a page. Usually, whilst the link is not appearing in a new tab, I can left click the same link (open in same tab) and the link will open instantly. This behaviour suggests to me that it may in some way be related to security, but not in a way that's obvious to me.

Environment - Windows 7 (64bit) - RTM Code from MSDN + IE8. I am running as an Administrator account.

share|improve this question

migrated from stackoverflow.com Oct 14 '09 at 12:07

This question came from our site for professional and enthusiast programmers.

1 Answer 1

up vote 1 down vote accepted

Things to try:

  • IE without add-ons : Click Start -> All Programs -> Accessories -> System Tools, and then click Internet Explorer (No Add-ons). If this solves the problem, see this article :
    Troubleshooting and Internet Explorer’s (No Add-ons) Mode.

  • Turn off totally User Account Control. If that solves the problem, look to refining User Account Control.

  • General Internet Explorer trouble-shooting:

    1. Open Internet Explorer.
    2. On the Tools menu, click Internet Options.
    3. Click the Advanced tab, and then click the Reset button. 4, On the Programs tab, under Internet programs, click Set Programs, then Set your Default Programs, select your e-mail program and click "Set this program as Default". Repeat for Internet Explorer.
    4. Click OK and close the dialogs.
share|improve this answer
    
I'm pretty sure it's related to Add ons, but not sure exactly how. I went a sligthly different route. Tools | Manage Addons. I turned off the three (Adobe pdf, Flash, and AVG Smart Scan) non MS ones I had running. I was almost immediately forced to turn Flash back on, because of a site I wanted to view. Then I wanted the pdf one back. During this experiment the situation was much better, no tab hangs at all. Was it the AVG one? Well I turned that back on too, still no tab hangs. So - inconclusive, ATM. I'm wondering if the sequence the addons start up in may be signficant. –  RichardHowells Oct 15 '09 at 8:24

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.