Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Youtube is blocked in my country, and I think they have blocked it from the DNS end of it, because when I run:

dig www.youtube.com

in my LINUX terminal then I get no answer, but when I run the same command targeted at another DNS server then I get some answers...The command is:

dig www.youtube.com @8.8.8.8

and the Answers are:

; <<>> DiG 9.8.1-P1 <<>> youtube.com @8.8.8.8
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 23527
;; flags: qr rd ra; QUERY: 1, ANSWER: 11, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;youtube.com.           IN  A

;; ANSWER SECTION:
youtube.com.        300 IN  A   173.194.39.38
youtube.com.        300 IN  A   173.194.39.35
youtube.com.        300 IN  A   173.194.39.41
youtube.com.        300 IN  A   173.194.39.36
youtube.com.        300 IN  A   173.194.39.39
youtube.com.        300 IN  A   173.194.39.46
youtube.com.        300 IN  A   173.194.39.40
youtube.com.        300 IN  A   173.194.39.32
youtube.com.        300 IN  A   173.194.39.34
youtube.com.        300 IN  A   173.194.39.33
youtube.com.        300 IN  A   173.194.39.37

;; Query time: 193 msec
;; SERVER: 8.8.8.8#53(8.8.8.8)
;; WHEN: Sat Feb  9 16:22:52 2013
;; MSG SIZE  rcvd: 205

The problem is that whenever I copy and paste an IP from that list into my browser, google.com opens instead of youtube! Can someone explain why is this happening? and how can I open youtube from its IP so that I can bypass the DNS lookup...

share|improve this question

migrated from stackoverflow.com Feb 15 '13 at 10:11

This question came from our site for professional and enthusiast programmers.

    
What is the answer to dig www.google.com @8.8.8.8? –  Johnsyweb Feb 9 '13 at 11:33
    
Answer is... www.google.com. 300 IN A 173.194.35.180 www.google.com. 300 IN A 173.194.35.176 www.google.com. 300 IN A 173.194.35.177 www.google.com. 300 IN A 173.194.35.178 www.google.com. 300 IN A 173.194.35.179 –  ArslanW Feb 9 '13 at 11:42
    
I guess it's youtube itself to filter out connections from certain countries. Anyway, try to access it by this website: silentsurf.co.uk –  Davide Berra Feb 11 '13 at 12:32
add comment

6 Answers

You can use 8.8.8.8 as your regular DNS server.

Or you can add "173.194.39.38 youtube.com" to your /etc/hosts file.

share|improve this answer
    
I dont see how that will help... my browser is google chorme and I want to access youtube from the internet... doing what you said will only tell my system that a certain ip is named what... youtube still wont open... –  ArslanW Feb 9 '13 at 11:46
2  
You asked how to bypass your DNS. This is how you do it. –  Joni Feb 9 '13 at 11:58
add comment

As user1763532 explained, hosting architecture are now all based on loadbalancing, mutiple ISP, multiple location, so try something like this

"telnet 173.194.39.35 80"

GET / HTTP/1.1

Host: www.youtube.com

Connection: close

post result,

if telnet on port 80 is ok, no firewall filtering

if you don't get anything with GET, maybe web filtering

try and let us know (for my curiosity which country are you from ?? is your username related ^^)

share|improve this answer
add comment

Yes, you can add google public DNS server into the system. To do that, type vi /etc/resolv.conf and then add "nameserver 8.8.8.8 to it. You also need to be root to do that.

share|improve this answer
add comment

The A entries are IP's of general Google servers, more likely load balancers or entry points to their infrastructure, all of which will have some form of virtual host policies.

The complexity of Google's infrastructure should be ignored to understand how this works, although it will function much like Apahce's virtual host files.

<VirtualHost _default_:80>
DocumentRoot /com/google/www
...
</VirtualHost>
<VirtualHost google.com:80>
DocumentRoot /com/google/www
...
</VirtualHost>
<VirtualHost youtube.com:80>
DocumentRoot /com/youtube/www
...
</VirtualHost>

What your seeing is Google's default destination if no URL/Host is given (accessed directly through IP), it passes you to the content servers for Google.com.

If you had passed Youtube.com as the URL/Host to one of the A IP's you would reach Youtube.com.

Edit

In answer to your question, you cant just enter the IP. As already answered you can set your computers DNS server to 8.8.8.8 or use another DNS service.

You could also use a proxy service.

share|improve this answer
    
okay, I see... so I tried 173.194.39.35/Youtube.com and a google page came saying the following URL does not exist on this server, error code 404.... Am I doing it wrong? –  ArslanW Feb 9 '13 at 11:50
    
hmmm... changing my default dns server doesnt seem to be helping... well anyways hanks for your time! –  ArslanW Feb 9 '13 at 12:04
    
I changed the default and secondary dns of my router, but still no luck... It is possible that the blocking in my country can be based on another technique... –  ArslanW Feb 9 '13 at 12:20
add comment

install proxy swithcer. The website is blocked, so the only way is to create a VPN or use a proxy. use spotflux, proxy switcher or hotspot sheild

share|improve this answer
add comment

DNS Settings aren't going to work. Countries are smarter than that :)

Use a proxy, there's a good plugin for firefox and probably a couple for [sigh]chrome[/sigh]

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.