Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am using VIM for a while, but never faces such a problem.

When i connect to my desktop Ubuntu PC via ssh from a tablet (Asus tf Prime) using terminal emulator (screen-256-colors) I got my vim in Chinese... On desktop it is correctly working in English.

I've tried to set

set langmenu=en_US.UTF-8
language en_US.UTF-8

but it do not help... See screenshotenter image description here

You may find my configuration on github

share|improve this question
up vote 0 down vote accepted

The problem was in bad linux package installed on desktop - vim-gnome 2:7.3.429-2ubuntu2.1

I've removed it and build vim from sources. And now have no issues at all. Setting "set langmenu" is not needed anymore: vim works great without it.

share|improve this answer

try

language message en_US.UTF-8 
share|improve this answer
    
What does that do? How does it help? – Moses Oct 30 '13 at 22:17

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .