Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am working to debug an issue where my PC randomly freezes after being idle. At one point I had disabled my page file, but noted I was not getting crash dumps because of this. I am running an SSD, so I did not want to have all 32gb of ram made into a page file, so I configured my system as such:

enter image description here

However, after reboot, I see a large pagefile.sys, and when I return to the Virtual Memory configuration option, it is set to "Automatically manage paging file size for all drives"

enter image description here

I have yet to figure out the crashing issue, so I am not sure if it is related. However, I think its odd that Windows configures the pagefile how it wants without asking me. I also do not see any memory dumps or crash logs (only the power event when I manually kill the power), that seems like it may be related.

Windows 7 64 bit (Microsoft Windows [Version 6.1.7601])


Update info which may be useful:

  • This does not appear to be related to the crashing, I had solved this a few months back with a bios firmware upgrade.
  • I am using ASROCK Extreme Tuning Utility and the XFast RAM feature. Thoughout this whole time the option for storing the page file in the ram disk (I am not sure why this exists), but in this configuration I have the memory pagefile turned off. Windows should still be in control of the pagefile and any settings. I cannot think of any other programs which may affect this.
share|improve this question
    
I think this may be related because its kind of the opposite: answers.microsoft.com/en-us/windows/forum/windows_7-performance/… ; however, I do not see any services named afs on my system - whenever I try to do anything with a service called afs I get an error like "The specified service does not exist as an installed service." –  Eric G Sep 6 '13 at 22:00

4 Answers 4

To use full-memory dumps in Windows, the pagefile must be the same size as the total RAM, or larger. In your case, that means it must be at least 32GB.

However, you could use "minidumps" which are significantly smaller.

Try this:

  1. Change your pagefile settings back to "no paging file" and reboot so that Windows deletes pagefile.sys.

    Note: Double-check that pagefile.sys was actually deleted after you reboot. To do this, use Windows Explorer to browse the system drive (usually C:) and look for pagefile.sys. You will probably have to go to Tools > Folder Options > View > 'Show hidden files, folders, and drives' > Apply to get it to show up (if it is there). If pagefile.sys is still there, delete it.

  2. Use the instructions at the bottom of this page to enable small memory dumps: Link

  3. Set the initial and maximum pagefile size for the system drive (usually C:) to the "minimum allowed" size listed at the bottom of the Virtual Memory settings window (your first screen shot does not show the very bottom, but that is the window I am referring to). It should be pretty small; mine is 16MB for example.

  4. Save the new Virtual Memory settings and reboot.

share|improve this answer
1  
Ahem... Isn't this already in my answer ? –  harrymc Sep 6 '13 at 6:00
    
@harrymc it does seem similar. Unfortunately, this does not wok on both counts. Whenever I restart windows, including via safemode, I cannot delete the pagefile.sys. I go back into my pagefile settings and "Automatically manage paging file size for all drives" will then be selected. In safemode, this was unchecked, but the radio button for "System managed size" was still present. After the first restart, the pagefile had shrunk to about 3GB, but still could not be deleted and was back to 32 after the next start. –  Eric G Sep 6 '13 at 21:36
    
@harrymc The only similarity I see is that part of my process involves deleting the pagefile. Although I also included the commonly known way to delete the pagefile, that was not the main information in my answer. Did you read the whole thing? The point was to get minidumps enabled to see if that allowed the pagefile to shrink. –  Jon Hoffman Sep 7 '13 at 8:28
    
@EricG Does pagefile.sys stay even when you select "no paging file" and reboot? –  Jon Hoffman Sep 7 '13 at 8:29
    
@JonHoffman yes. I have tried various options in both regular and safemode, it does not ever disappear on reboot or after changing the settings, nor does it allow me to delete it. –  Eric G Sep 7 '13 at 16:03

Windows may not have deleted the old pagefile.sys. Try to :

  • set to "No paging file"
  • reboot
  • delete C:\pagefile.sys (hidden file, and permissions may need to be managed)
  • reset to "Custom size"
  • reboot

If the setting for the page-file is reset by some program, you could try using Process Monitor to do Boot time logging of all registry changes in order to identify the program that changes it. Just remember that this slows the boot process a lot.

The page-file settings are found in the registry at HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management\. The value involved might be PagingFiles, but you can easily check which one by changing the Virtual Memory settings between System managed and Custom and refreshing the display in regedit to see what changed.

With this information you can set up a filter in Process Monitor and identify the process that changes that value in the registry.


The page file is used chiefly for swapping-out programs when the RAM is full. Its use for the dump is only incidental - a convenient place for Windows to put crash data. Its size therefore should be at least as large as your RAM. You should verify if Windows does not allocate a larger file when the specified allocation is too small, which seems to me a reasonable built-in safeguard for Windows to employ.

Remark: If you have another drive in addition to the SSD, you could move the page file there so as not to reduce it too much.

Another remark: Modern SSDs are rated for many gigabytes per day for up to a decade, so you really should have no fear of some 32 MB reducing the life-time of your disk. SSD longevity is no longer an issue unless the SSD is old or of low quality.

For example, a test by AnandTech came up with the following results :

image

If for example the daily usage is only 5 GB written, the above lifespan should be multiplied by a factor of two. A modern SSD should last for the lifetime of the computer.

share|improve this answer
    
I don't think it actually ever uses the page file, its really just the waste of space. Because I am using Truecrypt I think I want to avoid any weird complications that may result from the pagefile being on another drive. I really just want it to allow me to keep it small. –  Eric G Sep 6 '13 at 21:42
    
See this answer on a way to delete hiberfil.sys and use it for pagefile.sys when it is set to "No paging file", after rebooting in Safe mode. Let me know if this doesn't work. Otherwise, if you have encrypted the system drive with Truecrypt then booting a Linux CD to delete it won't work, so you might just try to relocate it to another disk - there shouldn't be any complication with the boot - and verify that it's really gone from C (you can then relocate it back but smaller). But Windows might not agree to allocate too small. –  harrymc Sep 7 '13 at 8:22
    
In addition, I have added a paragraph in my answer about the page file's size. –  harrymc Sep 7 '13 at 10:10
    
I don't use hibernation and this is not an access rights problem. –  Eric G Sep 7 '13 at 16:05
    
You misunderstood : substitute pagefile.sys wherever hiberfil.sys is mentioned in the link. And you certainly will have an access rights problem when trying to delete pagefile.sys - you don't think that Windows will let just anyone delete this crucial file? Also, your efforts with Jon Hoffman only reinforce my conviction that Windows will not let you create a too-small pagefile.sys, so relocating it may be your best option. –  harrymc Sep 7 '13 at 17:23

Have you checked that ReadyBoost is turned off?

Although Windows shouldn't be using the system drive (C:) for ReadyBoost, if it is turned on then Windows will use the whole available space on the drive for a page file.

This may not be the answer but it is worth checking.

http://windows.microsoft.com/en-gb/windows7/turn-readyboost-on-or-off-for-a-storage-device

share|improve this answer
    
There are no drives setup for ready boost on my system. –  Eric G Sep 2 '13 at 16:28

Check this link

Optimizing Your Memory Configuration

I found a 'Controlset001' and 'Controlset002' with different settings in each, causing a confliction. After deleting Controlset002 and removing 001 leaving 'ControlSet' - no further problems. But that was just me. Take the time to double check this, and make sure you have a backup to restore to, in case things go wrong.

share|improve this answer
    
Only one ControlSet is used (CurrentControlSet), so there can never be a conflict. –  harrymc Sep 7 '13 at 10:34

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.