Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Issue is that EFI systems only allow you to boot using FAT32. I have to deploy multiple images of Windows 8. My WIM image is larger than 4GB and unable to transfer to a FAT32 partition. I've been messing around for a couple days with no.success. Is their anyway to have a USB partition in 2 one in FAT32 and other in NTFS where the FAT32 partition could boot like grub2 or some other EFI bootloader and chaining to the install files over on my NTFS partition?


A little more information. A .WIM file holds the installation files when installing the Windows operating system. When you capture a Windows image its saved in a .wim file in the sources folder of a Windows installation disk. It is referenced as install.wim.

So the more updates and installation you make on the Windows operating system before you capture it to deploy increases the size. The size of my WIM file is more than 4 GB which cannot be transferred onto a FAT32 partition to install using an EFI system. I have tried REFIND and I was able to boot to the loader. What will really solve my problem is if anyone knows if and how to when adding a boot entry to point it to a next partition to load the boot manager. On the the FAT32 partition on my USB I have the REFiND and on the NTFS partition I have the Windows installation files. If their is someway I can point the REFIND loader menu entry to chainload the files on the NTFS partition. That way I can get around the EFI system boot restrictions of it having to boot from a FAT32 partition.

hope you understand what I am trying to accomplish here and if it's possible. I tried using a GRUB4DOS using the same scheme GRUB4DOS on the FAT32 partition and Windows iso file on the NTFS partition on my USB and it worked perfect when I pointed the menu entry to the next partition. Only problem is that GRUB4DOS is not a EFI loader so it doesn't work on my EFI tablet to boot from.

share|improve this question
    
Hi Kevin. Please register your account here, as you seem to have lost your cookie. You need to edit your question to add more info, not post an answer. Thanks! –  slhck Feb 17 '13 at 20:14
    
I have the same issue. Tried splitting the wims into swms but the install process doesn't like it. I'm currently booting off the FAT32 stick and then manually deploying the images using an NTFS USB HDD - not ideal. –  Damien Jun 15 '13 at 5:15
add comment

1 Answer

I'm not familiar with WIM or how it fits into the Windows boot scheme, so there may be an easier or better way to do this, but....

There are a number of EFI filesystem drivers available. Most of the ones I know of ship with my rEFInd boot manager: Ext2fs/ext3fs, ext4fs, ReiserFS, HFS+, and ISO-9660. I've also see an NTFS driver, but I don't know its provenance, or even if it's legal to use it (it came with no copyright notice), so I'm reluctant to recommend using it. It's conceivable you could use one of these drivers to get your large WIM file to work, but since I'm not familiar enough with the Windows boot process to know where that file must reside, I can't give more detailed suggestions. Obviously, using a Linux filesystem for Windows is a bit weird, but it might work if you dual-boot or if you install a Linux driver in Windows. ISO-9660 Level 3 might work, but I don't know if the EFI driver supports the extents feature required for this.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.