Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

just replaced my CD/DVD-ROM in my notebook with an SSD, installed Windows 8 on it but got a damn annoying problem - the computer can't boot by the UEFI, I get the error of winload.exe missing and the error code 0xc000000e.

The strange thing is that by pressing F12 when boothing (select boot device) and selecting the option "hard drive", the OS boots up normally.

I've tried many things now, one of the problems i suspected was that the System partition was empty, even through the Admin CMD as well, so no hidden files and such. Looking at the drive, maybe the problem is that the format is NTFS instead of FAT32, will try reformatting, but if I won't reply I did't succeed :P

Any ideas?

share|improve this question
add comment

2 Answers

It's been many versions since Windows last could run on FAT32. If you use a drive caddy in the CD/DVD bay, both for performance and other reasons I recommend that you replace the internal drive with the SSD and install the OS on it, and after installation place the original (now secondary) drive with user data in the caddy.

share|improve this answer
    
That would work, if it wasn't an Inspiron N5110... But the HDD is under the motherboard, and as such, I can't remove it without making the warranty void. I wished for any solution to tweak to boot files to make this thing work, though your answer would certainly work in any other case. –  Dracor Feb 16 '13 at 19:42
    
Can't you ask Dell whether you can replace the HDD with an SSD without voiding your warranty? (Don't mention the caddy.) –  Karan Feb 16 '13 at 19:43
    
I can't, the HDD can be only reached by completely disassembling the computer, including removing the motherboard screws, and all the cables that hold it in a place. I've already asked their technician when he came over to replace the motherboard because of overheating issues. –  Dracor Feb 16 '13 at 20:34
add comment

Chances are you accidentally installed Windows in BIOS mode rather than in EFI mode. It is possible to convert from a BIOS-mode to an EFI-mode installation, but the procedure is a bit tedious. (See here for details.) If your new Windows installation is your only OS, your best bet is probably to switch your firmware defaults to boot in BIOS mode. (It may be called "legacy mode," "CSM," or something else; firmware user interfaces on this point are woefully inconsistent.)

If you're dual-booting with another EFI-mode OS, it's conceivable that my rEFInd boot manager can help, since it's an EFI-mode boot manager that can launch either EFI-mode or BIOS-mode boot loaders. Unfortunately, rEFInd's BIOS-mode loading options are rather limited, so I can't guarantee it will work for you, particularly on a two-disk setup. It might be worth trying, though. If it will work at all, it requires you to uncomment the scanfor line in refind.conf and add hdbios to the list of options.

If rEFInd doesn't help or if you want to boot your new installation in EFI mode, another option is to re-install Windows. You'll need to figure out how to force the firmware to boot the installer in EFI mode, though. You'll also need to wipe the partition table on the target disk -- not just delete the partitions, but remove the entire partition table, since Windows ties that to its boot mode.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.