Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm installing IBM RAD 7.5 in Ubuntu 12.04 but when I run ./install it says

cannot execute binary file. 

When i run

chmod +x laucnhpad.sh
./lauchpad.sh

Then again not running.

drwxrwxr-x 12 sumeet sumeet   4096 Feb 17 01:01 .
drwxr-xr-x 26 sumeet sumeet   4096 Feb 19 21:52 ..
drwxr-xr-x  2 sumeet sumeet   4096 Nov  9 15:45 about_files
-rwxr-xr-x  1 sumeet sumeet    577 Nov  9 12:45 about.html
drwxr-xr-x  3 sumeet sumeet   4096 Nov  9 15:45 configuration
-rwxr-xr-x  1 sumeet sumeet   2225 Nov  9 15:45 consoleinst.sh
drwxr-xr-x 12 sumeet sumeet   4096 Nov  9 15:45 documentation
drwxr-xr-x  2 sumeet sumeet   4096 Nov  9 15:45 features
-rwxr-xr-x  1 sumeet sumeet  70058 May  9  2010 groupinst
-rwxr-xr-x  1 sumeet sumeet  70058 May  9  2010 groupinstc
-rwxr-xr-x  1 sumeet sumeet    219 Nov  9 15:45 groupinstc.ini
-rwxr-xr-x  1 sumeet sumeet    174 Nov  9 15:45 groupinst.ini
-rwxr-xr-x  1 sumeet sumeet  70058 May  9  2010 install
-rwxr-xr-x  1 sumeet sumeet  70058 May  9  2010 installc
-rwxr-xr-x  1 sumeet sumeet    217 Nov  9 15:45 installc.ini
-rwxr-xr-x  1 sumeet sumeet    172 Nov  9 15:45 install.ini
-rwxr-xr-x  1 sumeet sumeet    265 Nov  9 15:45 install.xml
drwxr-xr-x  4 sumeet sumeet   4096 Nov  9 15:45 jre_6.0.0.sr9_20110208_03
-rwxr-xr-x  1 sumeet sumeet 286876 Nov  9 12:45 libcairo-swt.so
drwxr-xr-x  2 sumeet sumeet   4096 Nov  9 15:45 license
drwxr-xr-x  2 sumeet sumeet   4096 Nov  9 15:45 native
drwxr-xr-x  2 sumeet sumeet   4096 Nov  9 15:45 Offerings
drwxr-xr-x  9 sumeet sumeet  61440 Nov  9 15:45 plugins
-rwxr-xr-x  1 sumeet sumeet   7786 Sep 12 16:59 readme_1.6.1.html
-rwxr-xr-x  1 sumeet sumeet    171 Nov  9 15:45 repository.config
-rwxr-xr-x  1 sumeet sumeet   4620 Nov  9 15:45 repository.xml
-rwxr-xr-x  1 sumeet sumeet    223 Nov  9 15:45 silent-install.ini
drwxr-xr-x  2 sumeet sumeet   4096 Nov  9 15:45 tools
-rwxr-xr-x  1 sumeet sumeet  70058 May  9  2010 userinst
-rwxr-xr-x  1 sumeet sumeet  70058 May  9  2010 userinstc
-rwxr-xr-x  1 sumeet sumeet    221 Nov  9 15:45 userinstc.ini
-rwxr-xr-x  1 sumeet sumeet    176 Nov  9 15:45 userinst.ini
-rwxr-xr-x  1 sumeet sumeet    230 Nov  9 15:45 user-silent-install.ini

sumeet@sumeet:~/agent$ uname -a
Linux sumeet 3.5.0-23-generic #35~precise1-Ubuntu SMP Fri Jan 25 17:15:33 UTC 2013 i686 i686 i386 GNU/Linux

sumeet@sumeet:~/agent$ file ./install
./install: ELF 32-bit MSB executable, PowerPC or cisco 4500, version 1 (SYSV), dynamically linked (uses shared libs), for GNU/Linux 2.2.5, not stripped
share|improve this question
    
Could you post the output of ls -la in the directory where ./install resides, file ./install and uname -a? – jaume Feb 16 '13 at 21:38
    
hey i have posted output for all these 3 command. – sambot Feb 19 '13 at 16:38
    
Thanks for posting it, the installer fails because there is an architecture mismatch, see my answer below for more information. – jaume Feb 19 '13 at 20:00
up vote 0 down vote accepted

Your Ubuntu runs on a 32-bit Intel based computer:

$ uname -a

Linux sumeet 3.5.0-23-generic #35~precise1-Ubuntu SMP Fri Jan 25 17:15:33 UTC 2013 i686 i686 i386 GNU/Linux

but ./install is compiled for another processor architecture, PowerPC, to be precise:

$ file ./install

./install: ELF 32-bit MSB executable, PowerPC or cisco 4500, version 1 (SYSV), dynamically linked (uses shared libs), for GNU/Linux 2.2.5, not stripped

So you have the wrong RAD package.

I could successfully download the latest version (8.5.1) for Linux from http://www.ibm.com/developerworks/downloads/r/rad/:

  • I used the Installation Manager method:

    enter image description here

  • I chose IBMIM_linux.zip in the HTTP download tab:

    enter image description here

and it was a 32-bit executable:

$ file ./install

install: ELF 32-bit LSB executable, Intel 80386, version 1 (SYSV), dynamically linked (uses shared libs), for GNU/Linux 2.2.5, not stripped

share|improve this answer
    
hey thanks for answer and explaining me :-) Actually i am participating in TGMC 2012 and IBM provided license for RAD 7.5. So have to use RAD 7.5 only. – sambot Feb 20 '13 at 13:59
    
I'm glad I could help you, good luck in TGMC. – jaume Feb 20 '13 at 14:01

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .