Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

So I have a computer I'm trying to turn into a media centre for the family. I installed Linux Mint 14 (which seems to be a bit all over the place if I'm honest, as most of the documentation for older Mint releases point to non-existent things, and there seems next-to-no documentation for anything besides the installation of 14; alas, I digress).

So the first few DVDs I tried worked - some kids DVDs (Thomas the Tank Engine!) which played first time. However few since have worked. The ones that work consistently work, the ones that don't consistently don't. Thus I'm ruling out a broken DVD drive.

Also 'libdvdcss2' and 'libdvdread4' are installed; I can't establish whether that is the only helpful library - there's 'ubuntu-restricted-extras' too, but is that for Mint and the wording implied it doesn't affect DVD playback?

So, some digging later, I managed to establish that DVDs that don't work are not mounting successfully. When I try to do it manually, I get this message:

  charles ~ # mount -t iso9660 /dev/sr1 /media/dvd
  mount: no medium found on /dev/sr1
  charles ~ # mount -o /dev/sr1 /media/dvd
  mount: can't find /media/dvd in /etc/fstab or /etc/mtab

I have confirmed via the Preferences > Disks utility that /dev/sr1 is the correct device (when a working DVD is inserted - when a non-working DVD is in, it says the drive is empty).

The DVDs are brand new, so they're not scratched or otherwise damaged. All the DVDs have been bought locally (UK).

To my knowledge, when Windows was installed all DVDs played back fine.

share|improve this question
    
do you have libdvdread3 installed in addition to libdvdcss2 and either the w32codecs or w64codecs? also have you tried dropping the type clause in your mount statement, or replacing it with -o ? –  Frank Thomas Feb 16 '13 at 23:20
    
Checked: libdvdread4 and w64codecs are installed. Result of -o added to question. –  Charles Goodwin Feb 17 '13 at 0:54

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.